aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/awstats/Makefile21
-rw-r--r--www/awstats/distinfo4
-rw-r--r--www/awstats/files/patch-wwwroot-cgi-bin-awstats.pl31
-rw-r--r--www/awstats/pkg-plist14
4 files changed, 24 insertions, 46 deletions
diff --git a/www/awstats/Makefile b/www/awstats/Makefile
index 6b8841646de0..fc18577cf75f 100644
--- a/www/awstats/Makefile
+++ b/www/awstats/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: awstats
-# Date created: May 13, 2002
-# Whom: Munish Chopra <mchopra@engmail.uwaterloo.ca>
-#
+# Created by: Munish Chopra <mchopra@engmail.uwaterloo.ca>
# $FreeBSD$
-#
PORTNAME= awstats
-PORTVERSION= 7.0
-PORTREVISION= 2
+PORTVERSION= 7.1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/AWStats/${PORTVERSION}
@@ -15,11 +10,11 @@ MASTER_SITES= SF/${PORTNAME}/AWStats/${PORTVERSION}
MAINTAINER= samm@os2.kiev.ua
COMMENT= Free real-time logfile analyzer to get advanced web statistics
-RUN_DEPENDS= p5-Net-XWhois>=0:${PORTSDIR}/net/p5-Net-XWhois
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/docs/LICENSE.TXT
+RUN_DEPENDS= p5-Net-XWhois>=0:${PORTSDIR}/net/p5-Net-XWhois
+
NO_BUILD= yes
USE_PERL5_RUN= yes
USE_DOS2UNIX= tools/*.pl \
@@ -37,11 +32,11 @@ USE_DOS2UNIX= tools/*.pl \
SUB_FILES= pkg-message
-OPTIONS= IPV6 "Enable IPV6 for use with IPv6 Plugin" Off
+OPTIONS_DEFINE= IPV6
.include <bsd.port.pre.mk>
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
RUN_DEPENDS+= p5-Net-IP>=0:${PORTSDIR}/net-mgmt/p5-Net-IP
RUN_DEPENDS+= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
.endif
@@ -107,14 +102,14 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/wwwroot/icon/os/* ${PREFIX}/www/awstats/icons/os
${INSTALL_DATA} ${WRKSRC}/wwwroot/icon/other/* ${PREFIX}/www/awstats/icons/other
${INSTALL_DATA} ${WRKSRC}/wwwroot/js/* ${PREFIX}/www/awstats/js
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/*.* ${DOCSDIR}
.endif
@${ECHO_CMD} ""
@${ECHO_CMD} "* Use ${PREFIX}/www/awstats/tools/awstats_configure.pl to setup your hosts."
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_CMD} "* Documentation has been installed in ${PREFIX}/share/doc/awstats"
.endif
@${ECHO_CMD} ""
diff --git a/www/awstats/distinfo b/www/awstats/distinfo
index e56237cbc117..88c95def5fce 100644
--- a/www/awstats/distinfo
+++ b/www/awstats/distinfo
@@ -1,2 +1,2 @@
-SHA256 (awstats-7.0.tar.gz) = e2651d4a5ff40e1d792b37cc13784d444cae479b4f98118aed27f46f5a18ce92
-SIZE (awstats-7.0.tar.gz) = 1254327
+SHA256 (awstats-7.1.tar.gz) = c58e8c57d567fadf3e948a3c27b4bc2d71e4aee04225c961cbc88ac380f8b38d
+SIZE (awstats-7.1.tar.gz) = 1260857
diff --git a/www/awstats/files/patch-wwwroot-cgi-bin-awstats.pl b/www/awstats/files/patch-wwwroot-cgi-bin-awstats.pl
deleted file mode 100644
index 80d82b0878ca..000000000000
--- a/www/awstats/files/patch-wwwroot-cgi-bin-awstats.pl
+++ /dev/null
@@ -1,31 +0,0 @@
---- wwwroot/cgi-bin/awstats.pl.orig 2011-07-06 08:11:37.000000000 +0100
-+++ wwwroot/cgi-bin/awstats.pl 2011-07-06 08:16:32.000000000 +0100
-@@ -1353,9 +1353,7 @@
- #------------------------------------------------------------------------------
- sub OptimizeArray {
- my $array = shift;
-- my @arrayunreg = map {
-- if (/\(\?[-\w]*:(.*)\)/) { $1 }
-- } @$array;
-+ my @arrayunreg = map { UnCompileRegex($_) } @$array;
- my $notcasesensitive = shift;
- my $searchlist = 0;
- if ($Debug) {
-@@ -3049,7 +3047,7 @@
- # Debian package : "/usr/share/awstats/plugins"
- my @PossiblePluginsDir = (
- "$DIR/plugins",
-- "/usr/local/awstats/wwwroot/cgi-bin/plugins",
-+ "%%PREFIX%%/www/awstats/cgi-bin/plugins",
- "/usr/share/awstats/plugins"
- );
- my %DirAddedInINC = ();
-@@ -7809,7 +7807,7 @@
- # Return: standardregex
- #------------------------------------------------------------------------------
- sub UnCompileRegex {
-- shift =~ /\(\?[-\w]*:(.*)\)/;
-+ shift =~ /\(\?[-^\w]*:(.*)\)/;
- return $1;
- }
-
diff --git a/www/awstats/pkg-plist b/www/awstats/pkg-plist
index 07a3fc636dfc..046743c62ff9 100644
--- a/www/awstats/pkg-plist
+++ b/www/awstats/pkg-plist
@@ -315,6 +315,10 @@ www/awstats/icons/cpu/mips.png
www/awstats/icons/cpu/motorola.png
www/awstats/icons/cpu/sun.png
www/awstats/icons/cpu/unknown.png
+www/awstats/icons/flags/sl.png
+www/awstats/icons/flags/me.png
+www/awstats/icons/flags/gg.png
+www/awstats/icons/flags/ax.png
www/awstats/icons/flags/a2.png
www/awstats/icons/flags/ac.png
www/awstats/icons/flags/ad.png
@@ -580,6 +584,10 @@ www/awstats/icons/flags/za.png
www/awstats/icons/flags/ze.png
www/awstats/icons/flags/zm.png
www/awstats/icons/flags/zw.png
+www/awstats/icons/mime/xsl.png
+www/awstats/icons/mime/document.png
+www/awstats/icons/mime/csv.png
+www/awstats/icons/mime/runtime.png
www/awstats/icons/mime/ai.png
www/awstats/icons/mime/archive.png
www/awstats/icons/mime/audio.png
@@ -619,6 +627,12 @@ www/awstats/icons/mime/video.png
www/awstats/icons/mime/wmv.png
www/awstats/icons/mime/glasses.png
www/awstats/icons/mime/xls.png
+www/awstats/icons/os/macosx8.png
+www/awstats/icons/os/macosx6.png
+www/awstats/icons/os/macosx7.png
+www/awstats/icons/os/macosx9.png
+www/awstats/icons/os/macosx4.png
+www/awstats/icons/os/macosx5.png
www/awstats/icons/os/aix.png
www/awstats/icons/os/amigaos.png
www/awstats/icons/os/apple.png