aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/hmat-oss/files/patch-CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/math/hmat-oss/files/patch-CMakeLists.txt b/math/hmat-oss/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..250754940b7a
--- /dev/null
+++ b/math/hmat-oss/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2022-10-05 15:44:52 UTC
++++ CMakeLists.txt
+@@ -255,9 +255,9 @@ include(CheckCCompilerFlag)
+ include(CheckCXXCompilerFlag)
+
+ function(hmat_set_compiler_flags _TARGET_NAME)
+- check_cxx_compiler_flag("-Werror -Wall" HAVE_COMPILER_WARNING_FLAGS)
++ check_cxx_compiler_flag("-Wall" HAVE_COMPILER_WARNING_FLAGS)
+ if(HAVE_COMPILER_WARNING_FLAGS)
+- target_compile_options(${_TARGET_NAME} PRIVATE -Werror -Wall)
++ target_compile_options(${_TARGET_NAME} PRIVATE -Wall)
+ foreach(flag -Wno-sign-compare;-Wno-undefined-var-template;-Wno-unused-parameter)
+ string(REPLACE "-" "_" varname ${flag})
+ check_cxx_compiler_flag("${flag}" CXX${varname})