aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-pip/Makefile15
-rw-r--r--devel/py-pip/distinfo6
-rw-r--r--devel/py-pip/pkg-plist7
3 files changed, 24 insertions, 4 deletions
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
index 839f94d1aa65..1fb0356b29a6 100644
--- a/devel/py-pip/Makefile
+++ b/devel/py-pip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pip
-PORTVERSION= 0.4
+PORTVERSION= 0.5.1
PORTREVISION= 0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP \
@@ -16,7 +16,20 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Pip installs (Python) packages. An easy_install replacement
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+REINPLACE_ARGS= -i.bak -e "s/env python$$/&${PYTHON_VER}/"
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+post-patch:
+ ${FIND} ${WRKSRC} -type f -name "pip*" -print0 | ${XARGS} -0 ${REINPLACE_CMD}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs/_build && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/py-pip/distinfo b/devel/py-pip/distinfo
index 8c3e84bc0782..7e80907be04e 100644
--- a/devel/py-pip/distinfo
+++ b/devel/py-pip/distinfo
@@ -1,3 +1,3 @@
-MD5 (pip-0.4.tar.gz) = b45714d04f8fd38fe8e3d4c7600b91a2
-SHA256 (pip-0.4.tar.gz) = 28fc67558874f71fddda7168f73595f1650523dce3bc5bf189713ecdfc1e456e
-SIZE (pip-0.4.tar.gz) = 50238
+MD5 (pip-0.5.1.tar.gz) = d4bdaa5f5f5bf8c6263ace75a0882232
+SHA256 (pip-0.5.1.tar.gz) = e27650538c41fe1007a41abd4cfd0f905b822622cbe1f8e7e09d1215af207694
+SIZE (pip-0.5.1.tar.gz) = 54633
diff --git a/devel/py-pip/pkg-plist b/devel/py-pip/pkg-plist
index 7f5d39df3e0c..266cb16f324f 100644
--- a/devel/py-pip/pkg-plist
+++ b/devel/py-pip/pkg-plist
@@ -3,3 +3,10 @@ bin/pip
%%PYTHON_SITELIBDIR%%/pip.py
%%PYTHON_SITELIBDIR%%/pip.pyc
%%PYTHON_SITELIBDIR%%/pip.pyo
+%%PORTDOCS%%%%DOCSDIR%%/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/requirement-format.html
+%%PORTDOCS%%%%DOCSDIR%%/search.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%