aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/vice/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 4aed48822fea..76a0f9659c4c 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -98,6 +98,13 @@ pre-configure:
.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif
+.if ${ARCH} == "i386"
+ ${REINPLACE_CMD} \
+ -e 's|^@HAVE_BSD_FREE_FALSE@|@HAVE_BSD_FREE2_TRUE@|' \
+ -e 's|^@HAVE_BSD_FREE_TRUE@|@HAVE_BSD_FREE_FALSE@|' \
+ -e 's|^@HAVE_BSD_FREE2_TRUE@|@HAVE_BSD_FREE_TRUE@|' \
+ ${WRKSRC}/src/Makefile.in
+.endif
pre-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}