aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/libpurple/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 2def4cb4c144..c7dd47fb6be2 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -77,6 +77,8 @@ PLIST_SUB+= GTKUI="@comment not installed: "
.endif
.if defined(WITH_CONSOLEUI)
+OPTIONS_DEFINE+=NCURSES
+NCURSES_DESC= Build with ncurses from ports
PLIST_SUB+= CONSOLEUI=""
.else
PLIST_SUB+= CONSOLEUI="@comment not installed: "
@@ -97,6 +99,13 @@ CONFIGURE_ARGS+= --disable-tcl
PLIST_SUB+= TCL:="@comment not installed: "
.endif
+.if ${PORT_OPTIONS:MNCURSES}
+USES+= ncurses:port
+CONFIGURE_ARGS+=--with-ncurses-headers=${LOCALBASE}/include/ncurses/
+.else
+USES+= ncurses
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(PIDGIN_SLAVE)