aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.mk2
-rw-r--r--Mk/bsd.port.mk16
-rw-r--r--audio/supercollider/Makefile2
-rw-r--r--devel/ElectricFence/files/patch-Makefile10
-rw-r--r--emulators/i386-wine-devel/Makefile.inc4
-rw-r--r--emulators/i386-wine/Makefile.inc4
-rw-r--r--emulators/rtc/files/Makefile4
-rw-r--r--graphics/drm-fbsd11.2-kmod/Makefile2
-rw-r--r--graphics/drm-fbsd11.2-kmod/pkg-descr2
-rw-r--r--graphics/drm-kmod/Makefile2
-rw-r--r--japanese/man/files/patch-man__Makefile15
-rw-r--r--multimedia/libva/Makefile1
-rw-r--r--net-mgmt/kapacitor/Makefile3
-rw-r--r--net/mpd5/files/patch-src-Makefile33
-rw-r--r--net/zerotier/Makefile2
-rw-r--r--security/ipsec-tools/Makefile4
16 files changed, 46 insertions, 60 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 5fe53a15fdfb..35bb5c02a265 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -37,7 +37,7 @@
# OPTIONS_EXCLUDE_${ARCH} - List of options unsupported on a given ${ARCH}
# OPTIONS_EXCLUDE_${OPSYS} - List of options unsupported on a given ${OPSYS}
# OPTIONS_EXCLUDE_${OPSYS}_${OSREL:R} - List of options unsupported on a given
-# ${OPSYS} and major version (8/9/10...)
+# ${OPSYS} and major version (11/12/13...)
# OPTIONS_SLAVE - This is designed for slave ports, it removes an
# option from the options list inherited from the
# master port and it always adds it to PORT_OPTIONS
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bad8a251ba5c..ebac68554f7c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -162,12 +162,12 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# IGNORE_${ARCH} - Port should be ignored on ${ARCH}.
# IGNORE_${OPSYS} - Port should be ignored on ${OPSYS}.
# IGNORE_${OPSYS}_${OSREL:R} - Port should be ignored on a single
-# release of ${OPSYS}, e.g IGNORE_FreeBSD_8
-# would affect all point releases of FreeBSD 8.
+# release of ${OPSYS}, e.g IGNORE_FreeBSD_13
+# would affect all point releases of FreeBSD 13.
# IGNORE_${OPSYS}_${OSREL:R}_${ARCH} - Port should be ignored on a
# single release of ${OPSYS} and specific architecture,
-# e.g IGNORE_FreeBSD_8_i386 would affect all point
-# releases of FreeBSD 8 in i386.
+# e.g IGNORE_FreeBSD_13_i386 would affect all point
+# releases of FreeBSD 13 in i386.
# BROKEN - Port is believed to be broken. Package builds can
# still be attempted using TRYBROKEN to test this
# assumption.
@@ -178,13 +178,13 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# can still be attempted using TRYBROKEN to
# test this assumption.
# BROKEN_${OPSYS}_${OSREL:R} - Port is believed to be broken on a single
-# release of ${OPSYS}, e.g BROKEN_FreeBSD_8
-# would affect all point releases of FreeBSD 8
+# release of ${OPSYS}, e.g BROKEN_FreeBSD_13
+# would affect all point releases of FreeBSD 13
# unless TRYBROKEN is also set.
# BROKEN_${OPSYS}_${OSREL:R}_${ARCH} - Port is believed to be broken on a
# single release of ${OPSYS} and specific architecture,
-# e.g BROKEN_FreeBSD_8_i386 would affect all point
-# releases of FreeBSD 8 in i386
+# e.g BROKEN_FreeBSD_13 would affect all point
+# releases of FreeBSD 13 in i386
# unless TRYBROKEN is also set.
# DEPRECATED - Port is deprecated to install. Advisory only.
# EXPIRATION_DATE
diff --git a/audio/supercollider/Makefile b/audio/supercollider/Makefile
index 74f648f52094..9a4f538f0f45 100644
--- a/audio/supercollider/Makefile
+++ b/audio/supercollider/Makefile
@@ -55,7 +55,7 @@ CMAKE_ARGS+= -DSSE:BOOL=FALSE -DSSE2:BOOL=FALSE
.endif
.if ${OPSYS} == FreeBSD
-.if (${OSVERSION} >= 1102507 && ${OSVERSION} < 1200000) || \
+.if ${OSVERSION} < 1200000 || \
(${OSVERSION} >= 1200506 && ${OSVERSION} < 1300000) || \
${OSVERSION} >= 1300014
BROKEN= fails to compile with Clang 8 due shipped Boost 1.66 libraries. Not compatible with Boost 1.70+, either
diff --git a/devel/ElectricFence/files/patch-Makefile b/devel/ElectricFence/files/patch-Makefile
index 83ffc2b0fb38..ff22e2c35e41 100644
--- a/devel/ElectricFence/files/patch-Makefile
+++ b/devel/ElectricFence/files/patch-Makefile
@@ -1,12 +1,12 @@
---- Makefile.orig Wed Apr 14 03:22:49 1999
-+++ Makefile Sun Oct 22 14:27:23 2006
+--- Makefile.orig 1999-04-13 17:22:49 UTC
++++ Makefile
@@ -1,8 +1,14 @@
PIC= -fPIC
-CFLAGS= -g -DUSE_SEMAPHORE $(PIC)
-LIBS= -lpthread
+#CFLAGS= -g -DUSE_SEMAPHORE $(PIC)
+CFLAGS+= -g $(PIC)
-+.if ${MACHINE_ARCH} == "i386" && ${OSVERSION} < 700003 || (${MACHINE_ARCH} == "amd64" && ${OSVERSION} < 700003) || ${MACHINE_ARCH} == "ia64" || ${MACHINE_ARCH} == "sparc64"
++.if ${MACHINE_ARCH} == "sparc64"
+CFLAGS+= -DPAGE_PROTECTION_VIOLATED_SIGNAL=SIGBUS
+.endif
+#CFLAGS+= -pthread
@@ -18,7 +18,7 @@
BIN_INSTALL_DIR= $(prefix)/bin
LIB_INSTALL_DIR= $(prefix)/lib
MAN_INSTALL_DIR= $(prefix)/man/man3
-@@ -17,14 +23,18 @@
+@@ -17,14 +23,18 @@ PACKAGE_SOURCE= README efence.3 Makefile efence.h \
OBJECTS= efence.o page.o print.o
all: libefence.a libefence.so.0.0 tstheap eftest
@@ -45,7 +45,7 @@
install: libefence.a efence.3 libefence.so.0.0
$(INSTALL) -m 755 ef.sh $(BIN_INSTALL_DIR)/ef
-@@ -54,16 +64,16 @@
+@@ -54,16 +64,16 @@ libefence.a: $(OBJECTS)
$(AR) crv libefence.a $(OBJECTS)
libefence.so.0.0: $(OBJECTS)
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index d23a29b1ab15..ec024401def5 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -65,8 +65,8 @@ PLIST_SUB+= OSREL${osrel}-DEVEL="@comment "
.endif
.endfor
-.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1102000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200086 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300003 && ${OSVERSION} < 1400000))
-IGNORE= binaries compiled for FreeBSD 11.2+, 12.0+ and -current only
+.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1103000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200086 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300003 && ${OSVERSION} < 1400000))
+IGNORE= binaries compiled for FreeBSD 11.3+, 12.0+ and -current only
DISTFILES=
.endif
diff --git a/emulators/i386-wine/Makefile.inc b/emulators/i386-wine/Makefile.inc
index 8c48617ad616..9b0c8b32ee9c 100644
--- a/emulators/i386-wine/Makefile.inc
+++ b/emulators/i386-wine/Makefile.inc
@@ -58,8 +58,8 @@ PLIST_SUB+= OSREL${osrel}="@comment "
.endif
.endfor
-.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1102000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200086 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300003 && ${OSVERSION} < 1400000))
-IGNORE= binaries compiled for FreeBSD 11.2+, 12.0+ and -current only
+.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1103000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200086 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300003 && ${OSVERSION} < 1400000))
+IGNORE= binaries compiled for FreeBSD 11.3+, 12.0+ and -current only
DISTFILES=
.endif
diff --git a/emulators/rtc/files/Makefile b/emulators/rtc/files/Makefile
index 32ea55733f2c..25d4f702cf52 100644
--- a/emulators/rtc/files/Makefile
+++ b/emulators/rtc/files/Makefile
@@ -28,11 +28,7 @@
SYS?= /sys
NOMAN= YES
KMOD= rtc
-.if ${OSVERSION} < 500002
-KMODDEPS= linux
-.else
MODULE_DEPEND= linux
-.endif
CDEV_MAJOR?= 202
DEVNAME= ${KMOD}
SRCS= rtc.c rtc_linux.c vnode_if.h
diff --git a/graphics/drm-fbsd11.2-kmod/Makefile b/graphics/drm-fbsd11.2-kmod/Makefile
index 05c7824bd4fa..c2470fe49132 100644
--- a/graphics/drm-fbsd11.2-kmod/Makefile
+++ b/graphics/drm-fbsd11.2-kmod/Makefile
@@ -32,7 +32,7 @@ GH_TAGNAME= 72300db
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && (${OSVERSION} < 1102000 || ${OSVERSION} > 1200000)
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200000
IGNORE= only supported on FreeBSD 11.
.endif
diff --git a/graphics/drm-fbsd11.2-kmod/pkg-descr b/graphics/drm-fbsd11.2-kmod/pkg-descr
index eda4c34dd5db..b422adefc5e2 100644
--- a/graphics/drm-fbsd11.2-kmod/pkg-descr
+++ b/graphics/drm-fbsd11.2-kmod/pkg-descr
@@ -1,6 +1,6 @@
amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components.
Currently corresponding to Linux 4.11 DRM.
-This version is for FreeBSD 11.2.
+This version is for FreeBSD 11.3.
amdgpu and radeonkms are known to fail with EFI boot.
WWW: https://github.com/FreeBSDDesktop/kms-drm
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
index b768d109cfb9..71ec1eeef89d 100644
--- a/graphics/drm-kmod/Makefile
+++ b/graphics/drm-kmod/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-legacy-kmod
IGNORE= legacy kmod not required on less than 12.0
.endif
.else
-.if ${OSVERSION} >= 1101510 && ${OSVERSION} < 1200000
+.if ${OSVERSION} >= 1103000 && ${OSVERSION} < 1200000
RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-fbsd11.2-kmod
.elif ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
IGNORE= not supported on older 12, no kernel support
diff --git a/japanese/man/files/patch-man__Makefile b/japanese/man/files/patch-man__Makefile
index c7ecd256ab0e..82aca7590a6c 100644
--- a/japanese/man/files/patch-man__Makefile
+++ b/japanese/man/files/patch-man__Makefile
@@ -1,6 +1,6 @@
---- man/Makefile.orig 2014-08-26 12:12:08.000000000 +0900
-+++ man/Makefile 2014-08-26 12:12:36.000000000 +0900
-@@ -10,14 +10,14 @@
+--- man/Makefile.orig 2019-10-10 18:39:59 UTC
++++ man/Makefile
+@@ -10,16 +10,13 @@ PROG= jman
SRCS= man.c manpath.c glob.c locale.c
MAN1= jman.1
EMAN1= jman.1.eng.gz
@@ -15,11 +15,12 @@
DPADD= ${LIBMAN}
LDADD= ${LIBMAN}
-.if exists(/usr/lib/libxpg4.a)
-+.if ${OSVERSION} < 400020
- LDADD+= -L/usr/lib -lxpg4
- .endif
+-LDADD+= -L/usr/lib -lxpg4
+-.endif
+
+ DPADD+= ${MAN1} ${EMAN1}
-@@ -48,16 +48,23 @@
+@@ -48,16 +45,23 @@ ${EMAN1}: ${.CURDIR}/jman.man.eng
${.CURDIR}/jman.man.eng | \
${compress} > ${EMAN1}
diff --git a/multimedia/libva/Makefile b/multimedia/libva/Makefile
index e0e7bd83ac07..69b3c782ac38 100644
--- a/multimedia/libva/Makefile
+++ b/multimedia/libva/Makefile
@@ -21,7 +21,6 @@ USE_LDCONFIG= yes
GH_ACCOUNT= intel
# -lpthread is not necessary if pthread_getthreadid_np is a libc stub
LDFLAGS+= ${LDFLAGS_${OPSYS}_${OSREL}}
-LDFLAGS_FreeBSD_11.2= -lpthread
LDFLAGS_FreeBSD_11.3= -lpthread
LDFLAGS_FreeBSD_12.0= -lpthread
diff --git a/net-mgmt/kapacitor/Makefile b/net-mgmt/kapacitor/Makefile
index afa81e390ff5..96476a0e343a 100644
--- a/net-mgmt/kapacitor/Makefile
+++ b/net-mgmt/kapacitor/Makefile
@@ -46,8 +46,7 @@ GROUPS= ${KAPACITORD_GROUP}
.include <bsd.port.pre.mk>
-.if ${OPSYS} == "FreeBSD" && ((${OSVERSION} >= 1100513 && ${OSVERSION} < 1200000) || \
- ${OSVERSION} >= 1200015)
+.if ${OPSYS} == "FreeBSD" && (${OSVERSION} < 1200000 || ${OSVERSION} >= 1200015)
SUB_LIST+= KAPACITORD_LOGCMD="daemon"
.else
SUB_LIST+= KAPACITORD_LOGCMD="logger"
diff --git a/net/mpd5/files/patch-src-Makefile b/net/mpd5/files/patch-src-Makefile
index 6b1e64a4df0f..bab99faea158 100644
--- a/net/mpd5/files/patch-src-Makefile
+++ b/net/mpd5/files/patch-src-Makefile
@@ -1,6 +1,6 @@
---- src/Makefile.orig 2016-01-06 22:42:06.000000000 +0700
-+++ src/Makefile 2018-11-25 13:48:31.977979000 +0700
-@@ -9,10 +9,20 @@
+--- src/Makefile.orig 2019-10-10 18:24:28 UTC
++++ src/Makefile
+@@ -9,9 +9,11 @@
PROG?= mpd5
PREFIX?= /usr/local
@@ -9,20 +9,11 @@
VERSION= 5.8
-NOMAN=
+
-+.if defined(OSVERSION)
-+.if ${OSVERSION} > 1100100
-+MK_MAN= no
-+.else
-+NO_MAN=
-+.endif
-+.else
+MK_MAN= no
NO_MAN=
-+.endif
BINOWN!= /usr/bin/id -n -u
- BINGRP!= /usr/bin/id -n -g
-@@ -60,9 +70,6 @@
+@@ -59,9 +61,6 @@ USE_TCP_WRAP= yes
USE_AUTH_PAM= yes
USE_AUTH_SYSTEM= yes
@@ -32,7 +23,7 @@
# Build without builtin web server.
#NOWEB= yes
-@@ -72,7 +79,7 @@
+@@ -71,7 +70,7 @@ SYSLOG_FACILITY= LOG_DAEMON
# Print wide protocol names instead of short names.
# Comment this line, to save about 10 KB space
@@ -41,7 +32,7 @@
# Reduce some internal structures size to save more memory
# This is to limit amount of active sessions
-@@ -84,27 +91,27 @@
+@@ -83,27 +82,27 @@ COPTS+= -DPROTO_NAME_LIST
## filter TCP accept connections
LDADD+= -lwrap
DPADD+= ${LIBWRAP}
@@ -73,7 +64,7 @@
.endif
LDADD+= -lnetgraph -lutil
-@@ -113,19 +120,12 @@
+@@ -112,19 +111,12 @@ DPADD+= ${LIBNETGRAPH}
LDADD+= -L/usr/lib -lradius
DPADD+= ${LIBRADIUS}
@@ -97,7 +88,7 @@
-Wcast-align \
-Wchar-subscripts \
-Wformat \
-@@ -135,15 +135,14 @@
+@@ -134,15 +126,14 @@ COPTS+= -Wall \
-Wnested-externs \
-Wpointer-arith \
-Wwrite-strings \
@@ -116,7 +107,7 @@
.endif
# Standard sources
-@@ -155,14 +154,13 @@
+@@ -154,14 +145,13 @@ STDSRCS= assert.c auth.c bund.c rep.c ccp.c cha
util.c vars.c eap.c msoft.c ippool.c
.if defined ( NOWEB )
@@ -133,7 +124,7 @@
PDPATH1= contrib/libpdel/util:contrib/libpdel/structs
PDPATH2= contrib/libpdel/structs/type
.if defined ( NOWEB )
-@@ -200,60 +198,59 @@
+@@ -199,60 +189,59 @@ PDELSRCS+= http_connection.c \
string_fp.c \
timeout_fp.c
.endif
@@ -209,7 +200,7 @@
.endif
.endif
-@@ -262,46 +259,46 @@
+@@ -261,46 +250,46 @@ COPTS+= -DUSE_NG_PRED1
.if defined ( ECP_DES )
SRCS+= ecp_dese.c
SRCS+= ecp_dese_bis.c
@@ -267,7 +258,7 @@
.endif
# Add in required support files and libraries
-@@ -310,15 +307,12 @@
+@@ -309,15 +298,12 @@ DPADD+= ${LIBCRYPTO}
.if exists ( /usr/lib/libexecinfo.so )
LDADD+= -lexecinfo
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 8f803c2a88c4..1644d0b03a9a 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -32,7 +32,7 @@ PLIST_FILES= bin/zerotier-cli bin/zerotier-idtool sbin/zerotier-one
.if ${OPSYS} == "FreeBSD"
# log output via syslog when daemon(8) supports it
-.if ((${OSVERSION} >= 1100513 && ${OSVERSION} < 1200000) || ${OSVERSION} >= 1200015)
+.if (${OSVERSION} < 1200000 || ${OSVERSION} >= 1200015)
SUB_LIST+= ZEROTIER_SYSLOG="-s debug -T zerotier"
.else
SUB_LIST+= ZEROTIER_SYSLOG=""
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 1ae23a232107..5f03efe0c911 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -39,7 +39,7 @@ OPTIONS_DEFAULT= ADMINPORT DEBUG DPD NATT FRAG HYBRID WCPSKEY
ADMINPORT_DESC= Enable Admin port
STATS_DESC= Statistics logging function
DPD_DESC= Dead Peer Detection
-NATT_DESC= NAT-Traversal (kernel-patch required before 11.1)
+NATT_DESC= NAT-Traversal
NATTF_DESC= require NAT-Traversal (fail without kernel-patch)
FRAG_DESC= IKE fragmentation payload support
HYBRID_DESC= Hybrid, Xauth and Mode-cfg support
@@ -82,7 +82,7 @@ WCPSKEY_EXTRA_PATCHES= ${FILESDIR}/wildcard-psk.diff ${FILESDIR}/wildcard-psk-oa
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100510
+.if ${OPSYS} == FreeBSD
REQUIREMOD?= ipsec
.endif