aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/merkaartor/Makefile2
-rw-r--r--astro/osmium/Makefile2
-rw-r--r--astro/qlandkartegt/Makefile2
-rw-r--r--databases/grass/Makefile2
-rw-r--r--graphics/R-cran-rgdal/Makefile1
-rw-r--r--graphics/gdal-grass/Makefile1
-rw-r--r--graphics/gdal-grass/files/patch-ogrgrass.h11
-rw-r--r--graphics/gdal-grass/files/patch-ogrgrasslayer.cpp11
-rw-r--r--graphics/gdal/Makefile5
-rw-r--r--graphics/gdal/distinfo4
-rw-r--r--graphics/gdal/pkg-plist5
-rw-r--r--graphics/gmt/Makefile2
-rw-r--r--graphics/mapnik/Makefile2
-rw-r--r--graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.cpp54
-rw-r--r--graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.hpp13
-rw-r--r--graphics/mapnik/files/patch-plugins-input-ogr-ogr_layer_ptr.hpp59
-rw-r--r--graphics/mapserver/Makefile2
-rw-r--r--graphics/osgearth/Makefile2
-rw-r--r--graphics/qgis/Makefile1
-rw-r--r--math/pdal/Makefile1
-rw-r--r--math/saga/Makefile1
21 files changed, 170 insertions, 13 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index df7b9d710924..4f9f6c02703d 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -16,6 +16,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
libproj.so:${PORTSDIR}/graphics/proj
+BROKEN= does not build with GDAL 2.0
+
USES= qmake tar:bzip2
USE_LDCONFIG= yes
diff --git a/astro/osmium/Makefile b/astro/osmium/Makefile
index 4d9095a9f96e..8581031f22f3 100644
--- a/astro/osmium/Makefile
+++ b/astro/osmium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osmium
PORTVERSION= git20130522
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/astro/qlandkartegt/Makefile b/astro/qlandkartegt/Makefile
index 267a9e29ff8c..65a98774e4c7 100644
--- a/astro/qlandkartegt/Makefile
+++ b/astro/qlandkartegt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qlandkartegt
PORTVERSION= 1.7.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/QLandkarte%20GT%20${PORTVERSION}
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 337e1330779a..a7248957fe1c 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grass
PORTVERSION= 6.4.4
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 2
CATEGORIES= databases geography
MASTER_SITES= http://grass.osgeo.org/%SUBDIR%/ \
diff --git a/graphics/R-cran-rgdal/Makefile b/graphics/R-cran-rgdal/Makefile
index 4a373076c422..d64796dc5bf3 100644
--- a/graphics/R-cran-rgdal/Makefile
+++ b/graphics/R-cran-rgdal/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rgdal
DISTVERSION= 1.0-4
+PORTREVISION= 1
CATEGORIES= graphics
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/graphics/gdal-grass/Makefile b/graphics/gdal-grass/Makefile
index a87d31697a27..1b8f7c20e84f 100644
--- a/graphics/gdal-grass/Makefile
+++ b/graphics/gdal-grass/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gdal-grass
PORTVERSION= 1.11.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://download.osgeo.org/gdal/
diff --git a/graphics/gdal-grass/files/patch-ogrgrass.h b/graphics/gdal-grass/files/patch-ogrgrass.h
new file mode 100644
index 000000000000..abe50e492787
--- /dev/null
+++ b/graphics/gdal-grass/files/patch-ogrgrass.h
@@ -0,0 +1,11 @@
+--- ogrgrass.h.orig 2015-02-06 15:30:50 UTC
++++ ogrgrass.h
+@@ -55,7 +55,7 @@ class OGRGRASSLayer : public OGRLayer
+
+ // Layer info
+ OGRFeatureDefn * GetLayerDefn() { return poFeatureDefn; }
+- int GetFeatureCount( int );
++ GIntBig GetFeatureCount( int );
+ OGRErr GetExtent(OGREnvelope *psExtent, int bForce);
+ virtual OGRSpatialReference *GetSpatialRef();
+ int TestCapability( const char * );
diff --git a/graphics/gdal-grass/files/patch-ogrgrasslayer.cpp b/graphics/gdal-grass/files/patch-ogrgrasslayer.cpp
new file mode 100644
index 000000000000..4de5ab09fe55
--- /dev/null
+++ b/graphics/gdal-grass/files/patch-ogrgrasslayer.cpp
@@ -0,0 +1,11 @@
+--- ogrgrasslayer.cpp.orig 2015-02-06 15:30:50 UTC
++++ ogrgrasslayer.cpp
+@@ -1013,7 +1013,7 @@ OGRErr OGRGRASSLayer::CreateFeature( OGR
+ /* Eventually we should consider implementing a more efficient */
+ /* way of counting features matching a spatial query. */
+ /************************************************************************/
+-int OGRGRASSLayer::GetFeatureCount( int bForce )
++GIntBig OGRGRASSLayer::GetFeatureCount( int bForce )
+ {
+ if( m_poFilterGeom != NULL || m_poAttrQuery != NULL )
+ return OGRLayer::GetFeatureCount( bForce );
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 6418b6488d49..d0cfb43bc3ce 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdal
-PORTVERSION= 1.11.2
-PORTREVISION= 3
+PORTVERSION= 2.0.0
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
@@ -47,7 +46,7 @@ MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
USES= gmake jpeg tar:xz
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+PLIST_SUB= MAJOR_VER=${PORTVERSION:R:R} PORTVERSION=${PORTVERSION}
PORTDATA= *
SLAVEDIRS= graphics/p5-Geo-GDAL graphics/php-gdal graphics/py-gdal graphics/ruby-gdal
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index 00c748da5c1c..82af70220193 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdal-1.11.2.tar.xz) = b7a18956dde45d636330d558a3a804684565f9356b517ddec223462f2430075f
-SIZE (gdal-1.11.2.tar.xz) = 6473004
+SHA256 (gdal-2.0.0.tar.xz) = 91704fafeea2349c5e268dc1e2d03921b3aae64b05ee01d59fdfc1a6b0ffc061
+SIZE (gdal-2.0.0.tar.xz) = 6967656
diff --git a/graphics/gdal/pkg-plist b/graphics/gdal/pkg-plist
index 1d822b66eb98..a798d06b790c 100644
--- a/graphics/gdal/pkg-plist
+++ b/graphics/gdal/pkg-plist
@@ -54,6 +54,7 @@ include/gdal_alg.h
include/gdal_alg_priv.h
include/gdal_csv.h
include/gdal_frmts.h
+include/gdal_mdreader.h
include/gdal_pam.h
include/gdal_priv.h
include/gdal_proxy.h
@@ -67,6 +68,8 @@ include/gdalgrid.h
include/gdalgrid_priv.h
include/gdaljp2abstractdataset.h
include/gdaljp2metadata.h
+include/gdaljp2metadatagenerator.h
+include/gdalsse_priv.h
include/gdalwarper.h
include/gdalwarpkernel_opencl.h
include/gvgcpfit.h
@@ -87,6 +90,6 @@ include/vrtdataset.h
lib/gdalplugins/.keepme
lib/libgdal.a
lib/libgdal.so
-lib/libgdal.so.1
+lib/libgdal.so.%%MAJOR_VER%%
lib/libgdal.so.%%PORTVERSION%%
libdata/pkgconfig/gdal.pc
diff --git a/graphics/gmt/Makefile b/graphics/gmt/Makefile
index 9452e71de4b9..b1521108846d 100644
--- a/graphics/gmt/Makefile
+++ b/graphics/gmt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gmt
PORTVERSION= 4.5.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.soest.hawaii.edu/%SUBDIR%/ \
ftp://ftp.geologi.uio.no/pub/%SUBDIR%/ \
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 639a985cf05e..15b8eecc32d4 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -4,7 +4,7 @@
PORTNAME= mapnik
PORTVERSION= 2.2.0
DISTVERSIONPREFIX= v
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= graphics geography
MASTER_SITES= http://mapnik.s3.amazonaws.com/dist/v${PORTVERSION}/
diff --git a/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.cpp b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.cpp
new file mode 100644
index 000000000000..b4a36f55ae95
--- /dev/null
+++ b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.cpp
@@ -0,0 +1,54 @@
+Obtained from: https://github.com/mapnik/mapnik/commit/f68291c5b47b5189d967dba01542262f2013da53
+ https://github.com/mapnik/mapnik/commit/f0821d897f66c31755f7012b68191a2ec7a060fb
+
+--- plugins/input/ogr/ogr_datasource.cpp.orig 2013-06-04 01:35:27 UTC
++++ plugins/input/ogr/ogr_datasource.cpp
+@@ -72,7 +72,11 @@ ogr_datasource::~ogr_datasource()
+ {
+ // free layer before destroying the datasource
+ layer_.free_layer();
++#if GDAL_VERSION_MAJOR >= 2
++ GDALClose(( GDALDatasetH) dataset_);
++#else
+ OGRDataSource::DestroyDataSource (dataset_);
++#endif
+ }
+
+ void ogr_datasource::init(mapnik::parameters const& params)
+@@ -82,6 +86,7 @@ void ogr_datasource::init(mapnik::parame
+ #endif
+
+ // initialize ogr formats
++ // NOTE: in GDAL >= 2.0 this is the same as GDALAllRegister()
+ OGRRegisterAll();
+
+ boost::optional<std::string> file = params.get<std::string>("file");
+@@ -112,17 +117,26 @@ void ogr_datasource::init(mapnik::parame
+
+ if (! driver.empty())
+ {
++#if GDAL_VERSION_MAJOR >= 2
++ unsigned int nOpenFlags = GDAL_OF_READONLY | GDAL_OF_VECTOR;
++ const char* papszAllowedDrivers[] = { driver.c_str(), NULL };
++ dataset_ = static_cast<gdal_dataset_type>(GDALOpenEx(dataset_name_.c_str(),nOpenFlags,papszAllowedDrivers,NULL,NULL));
++#else
+ OGRSFDriver * ogr_driver = OGRSFDriverRegistrar::GetRegistrar()->GetDriverByName(driver.c_str());
+ if (ogr_driver && ogr_driver != NULL)
+ {
+ dataset_ = ogr_driver->Open((dataset_name_).c_str(), FALSE);
+ }
+-
++#endif
+ }
+ else
+ {
+ // open ogr driver
+- dataset_ = OGRSFDriverRegistrar::Open((dataset_name_).c_str(), FALSE);
++#if GDAL_VERSION_MAJOR >= 2
++ dataset_ = static_cast<gdal_dataset_type>(OGROpen(dataset_name_.c_str(), FALSE, NULL));
++#else
++ dataset_ = OGRSFDriverRegistrar::Open(dataset_name_.c_str(), FALSE);
++#endif
+ }
+
+ if (! dataset_)
diff --git a/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.hpp b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.hpp
new file mode 100644
index 000000000000..2e5499117a43
--- /dev/null
+++ b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_datasource.hpp
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/mapnik/mapnik/commit/f68291c5b47b5189d967dba01542262f2013da53
+
+--- plugins/input/ogr/ogr_datasource.hpp.orig
++++ plugins/input/ogr/ogr_datasource.hpp
+@@ -63,7 +63,7 @@ class ogr_datasource : public mapnik::datasource
+ mapnik::datasource::datasource_t type_;
+ std::string dataset_name_;
+ std::string index_name_;
+- OGRDataSource* dataset_;
++ gdal_dataset_type dataset_;
+ ogr_layer_ptr layer_;
+ std::string layer_name_;
+ mapnik::layer_descriptor desc_;
diff --git a/graphics/mapnik/files/patch-plugins-input-ogr-ogr_layer_ptr.hpp b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_layer_ptr.hpp
new file mode 100644
index 000000000000..48027289f658
--- /dev/null
+++ b/graphics/mapnik/files/patch-plugins-input-ogr-ogr_layer_ptr.hpp
@@ -0,0 +1,59 @@
+Obtained from: https://github.com/mapnik/mapnik/commit/f68291c5b47b5189d967dba01542262f2013da53
+ https://github.com/mapnik/mapnik/commit/f0821d897f66c31755f7012b68191a2ec7a060fb
+
+--- plugins/input/ogr/ogr_layer_ptr.hpp.orig
++++ plugins/input/ogr/ogr_layer_ptr.hpp
+@@ -29,9 +29,16 @@
+ // stl
+ #include <stdexcept>
+
+-// ogr
++// gdal
++#include <gdal_version.h>
+ #include <ogrsf_frmts.h>
+
++#if GDAL_VERSION_MAJOR >= 2
++typedef GDALDataset* gdal_dataset_type;
++#else
++typedef OGRDataSource* gdal_dataset_type;
++#endif
++
+ class ogr_layer_ptr
+ {
+ public:
+@@ -62,7 +69,7 @@ class ogr_layer_ptr
+ is_valid_ = false;
+ }
+
+- void layer_by_name(OGRDataSource* const datasource,
++ void layer_by_name(gdal_dataset_type const datasource,
+ std::string const& layer_name)
+ {
+ free_layer();
+@@ -84,7 +91,7 @@ class ogr_layer_ptr
+ #endif
+ }
+
+- void layer_by_index(OGRDataSource* const datasource,
++ void layer_by_index(gdal_dataset_type const datasource,
+ int layer_index)
+ {
+ free_layer();
+@@ -110,7 +117,7 @@ class ogr_layer_ptr
+ #endif
+ }
+
+- void layer_by_sql(OGRDataSource* const datasource,
++ void layer_by_sql(gdal_dataset_type const datasource,
+ std::string const& layer_sql)
+ {
+ free_layer();
+@@ -179,7 +186,7 @@ class ogr_layer_ptr
+ }
+ #endif
+
+- OGRDataSource* datasource_;
++ gdal_dataset_type datasource_;
+ OGRLayer* layer_;
+ std::string layer_name_;
+ bool owns_layer_;
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 0660302f9baf..134de1bf4859 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 6.4.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
diff --git a/graphics/osgearth/Makefile b/graphics/osgearth/Makefile
index dd3b5665c3ca..fcd9844ce038 100644
--- a/graphics/osgearth/Makefile
+++ b/graphics/osgearth/Makefile
@@ -4,7 +4,7 @@
PORTNAME= osgearth
PORTVERSION= 2.5
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics geography
MAINTAINER= coder@tuxfamily.org
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 95ecd097e78a..abd071a52466 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qgis
PORTVERSION= 2.10.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MAINTAINER= rhurlin@gwdg.de
diff --git a/math/pdal/Makefile b/math/pdal/Makefile
index 51822a0a16af..a63f0f901306 100644
--- a/math/pdal/Makefile
+++ b/math/pdal/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pdal
PORTVERSION= 0.9.8
+PORTREVISION= 1
CATEGORIES= math databases graphics
MAINTAINER= coder@tuxfamily.org
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 5ed08b435f32..18a50d7ed063 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -3,6 +3,7 @@
PORTNAME= saga
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}