aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/libbdplus/Makefile26
-rw-r--r--multimedia/libbdplus/distinfo2
-rw-r--r--multimedia/libbdplus/pkg-descr6
-rw-r--r--multimedia/libbdplus/pkg-plist7
-rw-r--r--multimedia/libbluray/Makefile.include10
5 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/libbdplus/Makefile b/multimedia/libbdplus/Makefile
new file mode 100644
index 000000000000..17dc55f0e853
--- /dev/null
+++ b/multimedia/libbdplus/Makefile
@@ -0,0 +1,26 @@
+# Created by: kamikaze@bsdforen.de
+# $FreeBSD$
+
+PORTNAME= libbdplus
+PORTVERSION= 0.1.2
+CATEGORIES= multimedia
+MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
+ http://blu.opsec.eu/
+
+MAINTAINER= kami@freebsd.org
+COMMENT= BD+ System research implementation
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
+
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf aclocal automake
+USES= tar:bzip2 pkgconfig libtool
+
+CONFIGURE_ARGS= --without-libaacs
+
+.include "${.CURDIR}/../libbluray/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/multimedia/libbdplus/distinfo b/multimedia/libbdplus/distinfo
new file mode 100644
index 000000000000..c7b46e7fb067
--- /dev/null
+++ b/multimedia/libbdplus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libbdplus-0.1.2.tar.bz2) = a631cae3cd34bf054db040b64edbfc8430936e762eb433b1789358ac3d3dc80a
+SIZE (libbdplus-0.1.2.tar.bz2) = 319828
diff --git a/multimedia/libbdplus/pkg-descr b/multimedia/libbdplus/pkg-descr
new file mode 100644
index 000000000000..8bee94b065f2
--- /dev/null
+++ b/multimedia/libbdplus/pkg-descr
@@ -0,0 +1,6 @@
+libbdplus is a research project to implement the BD+ System Specifications.
+
+This research project provides, through an open-source library, a way to
+understand how the BD+ works.
+
+WWW: http://www.videolan.org/developers/libbdplus.html
diff --git a/multimedia/libbdplus/pkg-plist b/multimedia/libbdplus/pkg-plist
new file mode 100644
index 000000000000..2ed923700897
--- /dev/null
+++ b/multimedia/libbdplus/pkg-plist
@@ -0,0 +1,7 @@
+include/libbdplus/bdplus-version.h
+include/libbdplus/bdplus.h
+lib/libbdplus.a
+lib/libbdplus.so
+lib/libbdplus.so.0
+lib/libbdplus.so.0.1.0
+libdata/pkgconfig/libbdplus.pc
diff --git a/multimedia/libbluray/Makefile.include b/multimedia/libbluray/Makefile.include
new file mode 100644
index 000000000000..1aa0f64e186a
--- /dev/null
+++ b/multimedia/libbluray/Makefile.include
@@ -0,0 +1,10 @@
+# Makefile with common configure and install flags for libbluray
+# related ports.
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix="${PREFIX}"
+CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/libdata/pkgconfig"
+
+MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
+ CFLAGS=${CFLAGS:Q}
+