aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/musescore/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index c62a49bcaf91..13a19ee01c51 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -41,12 +41,14 @@ CMAKE_ARGS+= -DUSE_SYSTEM_FREETYPE="ON" \
-DBUILD_PCH=OFF \
-DDOWNLOAD_SOUNDFONT=OFF
-# WebEngine is only available on i386/amd64; defaults to ON there.
+# WebEngine is only available on i386/amd64, amd ppc64 starting FreeBSD 13.0.
# If enabled on arches that don't have WebEngine, the build breaks.
OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO WEBENGINE
OPTIONS_DEFAULT= PORTAUDIO
OPTIONS_DEFAULT_amd64= WEBENGINE
OPTIONS_DEFAULT_i386= WEBENGINE
+OPTIONS_DEFAULT_powerpc64= ${OPTIONS_DEFAULT_powerpc64_${OSREL:R}}
+OPTIONS_DEFAULT_powerpc64_13= WEBENGINE
WEBENGINE_DESC= Use WebEngine in the welcome panel