aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/openfire/Makefile13
-rw-r--r--net-im/openfire/distinfo6
-rw-r--r--net-im/openfire/pkg-plist3
3 files changed, 10 insertions, 12 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 81b34bd50f21..c668996b4c50 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openfire
-PORTVERSION= 4.0.3
+PORTVERSION= 4.0.4
PORTEPOCH= 1
CATEGORIES= net-im java
MASTER_SITES= http://download.igniterealtime.org/openfire/
@@ -12,6 +12,7 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= Enterprise instant messaging server
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.html
RUN_DEPENDS= slf4j>=1.7.7:devel/slf4j
@@ -26,6 +27,7 @@ USE_LDCONFIG= yes
USE_ANT= yes
USE_JAVA= yes
JAVA_VERSION= 1.8
+NO_ARCH= yes
CPE_VENDOR= igniterealtime
@@ -56,8 +58,10 @@ do-install:
(cd ${INSTALL_WRKSRC}/lib && ${INSTALL} -m 744 *.jar ${STAGEDIR}${DATADIR}/lib)
(cd ${INSTALL_WRKSRC}/lib && ${INSTALL} -m 744 log4j.xml ${STAGEDIR}${DATADIR}/lib)
- (cd ${INSTALL_WRKSRC}/resources && ${FIND} . \! -path ./security\* \
- | ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/resources)
+ (cd ${INSTALL_WRKSRC}/resources && \
+ ${FIND} . \! -path ./security\* \! -path ./nativeAuth\* | \
+ ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} \
+ ${STAGEDIR}${DATADIR}/resources)
# always install admin interface
(cd ${INSTALL_WRKSRC}/plugins/admin && ${FIND} . \
@@ -87,7 +91,4 @@ do-install-DOCS-on:
(cd ${WRKSRC}/documentation/docs && ${FIND} . \! -path ./javadoc\* \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1 )
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${DATADIR}/resources/nativeAuth/linux-i386/libshaj.so
-
.include <bsd.port.mk>
diff --git a/net-im/openfire/distinfo b/net-im/openfire/distinfo
index fa183a81b1d4..ec83e59b0494 100644
--- a/net-im/openfire/distinfo
+++ b/net-im/openfire/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477829402
-SHA256 (openfire_src_4_0_3.zip) = 349d90076453cdf17f2151cdf6df0eaf6d2c1f0fdc5f61f79e8d0b1afb492153
-SIZE (openfire_src_4_0_3.zip) = 103406252
+TIMESTAMP = 1481108226
+SHA256 (openfire_src_4_0_4.zip) = b97e492de79d8733f484f7575343df6eb108a26b3117dbca2666aba31319d39a
+SIZE (openfire_src_4_0_4.zip) = 103408213
diff --git a/net-im/openfire/pkg-plist b/net-im/openfire/pkg-plist
index d249a0b8dcda..ce336d9aba7b 100644
--- a/net-im/openfire/pkg-plist
+++ b/net-im/openfire/pkg-plist
@@ -344,9 +344,6 @@
%%DATADIR%%/resources/database/upgrade/9/openfire_postgresql.sql
%%DATADIR%%/resources/database/upgrade/9/openfire_sqlserver.sql
%%DATADIR%%/resources/database/upgrade/9/openfire_sybase.sql
-%%DATADIR%%/resources/nativeAuth/linux-i386/libshaj.so
-%%DATADIR%%/resources/nativeAuth/osx-ppc/libshaj.jnilib
-%%DATADIR%%/resources/nativeAuth/win32-x86/shaj.dll
%%DATADIR%%/resources/security
%%DATADIR%%/resources/spank/WEB-INF/web.xml
%%DATADIR%%/resources/spank/index.html