aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/fasta3/Makefile38
-rw-r--r--biology/fasta3/distinfo6
-rw-r--r--biology/fasta3/files/patch-Makefile66
-rw-r--r--biology/fasta3/files/patch-Makefile.common20
-rw-r--r--biology/fasta3/files/patch-comp_thr.c11
-rw-r--r--biology/fasta3/files/patch-compacc.c11
-rw-r--r--biology/fasta3/files/patch-complib.c11
-rw-r--r--biology/fasta3/files/patch-scaleswn.c11
-rw-r--r--biology/fasta3/files/pkg-message.in16
-rw-r--r--biology/fasta3/pkg-message15
-rw-r--r--biology/fasta3/pkg-plist117
11 files changed, 155 insertions, 167 deletions
diff --git a/biology/fasta3/Makefile b/biology/fasta3/Makefile
index 684c75fc0bc0..57737bce2a0f 100644
--- a/biology/fasta3/Makefile
+++ b/biology/fasta3/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# New ports collection makefile for: fasta3
# Date created: 29 January 2001
# Whom: Johann Visagie <johann@egenetics.com>
@@ -6,21 +7,25 @@
#
PORTNAME= fasta3
-PORTVERSION= 33.t08.d4
+PORTVERSION= 34.t25.d4
CATEGORIES= biology
MASTER_SITES= ftp://ftp.virginia.edu/pub/fasta/
DISTNAME= fasta${PORTVERSION:S/.//g}
EXTRACT_SUFX= .shar.Z
MAINTAINER= fernan@iib.unsam.edu.ar
-COMMENT= A collection of programs for searching DNA and protein databases, v3
+COMMENT= A collection of programs for searching DNA and protein databases
-NO_CDROM= May not be sold or incorporated into a commercial product
-WRKSRC= ${WRKDIR}/fasta3
-PKGMESSAGE= ${WRKDIR}/pkg-message
-FASTA3_DOCDIR= ${PREFIX}/share/doc/fasta3
-FASTA3_DOCS= 00README.1st README COPYRIGHT fasta3x.me fasta3x.doc \
- readme.*
+NO_CDROM= "May not be sold or incorporated into a commercial product"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= pkg-message
+
+MAKE_ENV+= THR_LIBS=${PTHREAD_LIBS}
+
+FASTA3_DOCS= README COPYRIGHT FASTA_LIST fasta3x.me fasta3x.doc \
+ fasta20.doc fasta_func.doc readme.* fasta.defaults
+DATA= *.mat
+EXAMPLES= *.aa *.lc *.seq
MAN1= fasta3.1 fastf3.1 fasts3.1 map_db.1 prss3.1
MLINKS= fasta3.1 tfasta3.1 fasta3.1 fastx3.1 fasta3.1 tfastx3.1 \
@@ -35,19 +40,24 @@ do-extract:
done
post-install:
- @ ${INSTALL_DATA} ${WRKSRC}/fastlibs ${PREFIX}/etc/fastlibs.sample
+ ${INSTALL_DATA} ${WRKSRC}/fastlibs ${PREFIX}/etc/fastlibs.sample
+ @ ${MKDIR} ${DATADIR}
+.for data in ${DATA}
+ ${INSTALL_DATA} ${WRKSRC}/${data} ${DATADIR}
+.endfor
+ @ ${MKDIR} ${EXAMPLESDIR}
+.for ex in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
+.endfor
.for manpage in ${MAN1}
@ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MAN1PREFIX}/man/man1/
.endfor
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${FASTA3_DOCDIR}
+ @ ${MKDIR} ${DOCSDIR}
.for docfile in ${FASTA3_DOCS}
- @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${FASTA3_DOCDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif
-.if !defined(BATCH)
- @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
@ ${CAT} ${PKGMESSAGE}
-.endif
.include <bsd.port.mk>
diff --git a/biology/fasta3/distinfo b/biology/fasta3/distinfo
index 722c05cae001..b3a5a21e3280 100644
--- a/biology/fasta3/distinfo
+++ b/biology/fasta3/distinfo
@@ -1,3 +1,3 @@
-MD5 (fasta33t08d4.shar.Z) = e6217268e122b2ca7c51b443425e40e3
-SHA256 (fasta33t08d4.shar.Z) = f2eb329393cd330c6848cff2a147fcc2c2f74dff6033cf7ba70177ab4bcca231
-SIZE (fasta33t08d4.shar.Z) = 685912
+MD5 (fasta34t25d4.shar.Z) = 554190cb7bf2488150a96e309651e9c7
+SHA256 (fasta34t25d4.shar.Z) = 4d901bc738074c6c72d568b3852cf7e8a91a71ca25a1b2d74b8b1ae997d956fe
+SIZE (fasta34t25d4.shar.Z) = 799416
diff --git a/biology/fasta3/files/patch-Makefile b/biology/fasta3/files/patch-Makefile
index 8930300dacd2..60b18c9b84a0 100644
--- a/biology/fasta3/files/patch-Makefile
+++ b/biology/fasta3/files/patch-Makefile
@@ -1,49 +1,33 @@
---- Makefile.orig Mon May 7 11:36:23 2001
-+++ Makefile Mon May 7 11:40:36 2001
-@@ -12,13 +12,13 @@
+--- Makefile.orig Thu Feb 9 12:03:37 2006
++++ Makefile Thu Feb 9 12:07:21 2006
+@@ -7,7 +7,7 @@
+ # in dropnfa.c (wrp 3/19/1998)
+ #
- # use -DBIG_LIB64 to generate 64-bit offsets in map_db .xin files
+-CC= gcc -g -O3
++#CC= gcc -g -O3
+ #CC=gcc -Wall -pedantic -ansi -g -O
+ #CC = gcc -g -DDEBUG
+ #CC= /opt/parasoft/bin.linux2/insure -g -pg -DDEBUG
+@@ -21,7 +21,7 @@
+ #CFLAGS= -DSHOWSIM -DUNIX -DTIMES -DHZ=100 -DSFCHAR="'|'" -c -DMAX_WORKERS=2 -DTHR_EXIT=pthread_exit -DPROGRESS -DSUPERFAMNUM -DUSE_MMAP -D_REENTRANT -DBIG_LIB64 -D_LARGE_FILE_SOURCE -DUSE_FSEEKO -D_FILE_OFFSET_BITS=64 -DHAS_INTTYPES -DSAMP_STATS
--CC= cc -O -std1
-+#CC= cc -O -std1
- #CC= insure -g -DDEBUG
- #CC= cc -g -DDEBUG -std1
- #CC= gcc -g -Wall
- #
- # standard line for normal searching
--CFLAGS= -DM10_CONS -DUNIX -DTIMES -DHZ=60 -DBIGMEM -DMAX_WORKERS=4 -DTHR_EXIT=pthread_exit -DPROGRESS -DFASTA_HOST='"fasta.bioch.virginia.edu/fasta/cgi"' -DIS_LITTLE_ENDIAN -DUSE_MMAP
-+CFLAGS+= -DM10_CONS -DUNIX -DTIMES -DHZ=60 -DBIGMEM -DMAX_WORKERS=4 -DTHR_EXIT=pthread_exit -DPROGRESS -DFASTA_HOST='"fasta.bioch.virginia.edu/fasta/cgi"' -DIS_LITTLE_ENDIAN -DUSE_MMAP
+ # standard options
+-CFLAGS= -DSHOWSIM -DUNIX -DTIMES -DHZ=100 -DSFCHAR="':'" -c -DMAX_WORKERS=2 -DTHR_EXIT=pthread_exit -DPROGRESS -DFASTA_HOST='"wrpx00.bioch.virginia.edu/fasta/cgi"' -DUSE_MMAP -D_REENTRANT -DHAS_INTTYPES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_FSEEKO -DSAMP_STATS -DPGM_DOC
++CFLAGS+= -DSHOWSIM -DUNIX -DTIMES -DHZ=100 -DSFCHAR="':'" -c -DMAX_WORKERS=2 -DTHR_EXIT=pthread_exit -DPROGRESS -DFASTA_HOST='"wrpx00.bioch.virginia.edu/fasta/cgi"' -DUSE_MMAP -D_REENTRANT -DHAS_INTTYPES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_FSEEKO -DSAMP_STATS -DPGM_DOC
# -I/usr/local/include/mysql -DMYSQL_DB
- #(for mySQL databases) (also requires change to Makefile33.common)
-
-@@ -32,11 +32,15 @@
- HFLAGS= -o
- NFLAGS= -o
+ #
+ #(for mySQL databases) (also requires change to Makefile34.common)
+@@ -35,10 +35,10 @@
--#for DEC Unix V4.0
- THR_SUBS = pthr_subs
--THR_LIBS = -threads
-+THR_LIBS = -pthread
+ # for Linux
+ THR_SUBS = pthr_subs2
+-THR_LIBS = -lpthread
++#THR_LIBS = -lpthread
THR_CC =
-+#for DEC Unix V4.0
-+#THR_SUBS = pthr_subs
-+#THR_LIBS = -threads
-+#THR_CC =
-+#
- #for Sun
- #THR_SUBS = uthr_subs
- #THR_LIBS = -lthread
-@@ -53,9 +57,9 @@
- #THR_LIBS = -lpthreads
- #THR_CC =
-
--XDIR = /seqprg/slib/bin
+-XDIR = /seqprg/bin
+XDIR = ${PREFIX}/bin
- # renamed (fasta33) programs
--include Makefile33.common
-+#include Makefile33.common
- # conventional (fasta3) names
--#include Makefile.common
-+include Makefile.common
+ DROPNFA_O = drop_nfa.o
+ DROPGSW_O = dropgsw.o
diff --git a/biology/fasta3/files/patch-Makefile.common b/biology/fasta3/files/patch-Makefile.common
deleted file mode 100644
index 395da695e031..000000000000
--- a/biology/fasta3/files/patch-Makefile.common
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.common.orig Mon Jan 29 12:42:32 2001
-+++ Makefile.common Mon Jan 29 13:44:06 2001
-@@ -46,7 +46,7 @@
- XTPROGS = fastx33_t tfastx33_t fasty33_t tfasty33_t
- XPROGS = fastx33 tfastx33 fasty33 tfasty33
-
--PROGS = $(SPROGS) $(TPROGS)
-+PROGS = $(SPROGS) $(TPROGS) $(APROGS) $(XTPROGS) $(XPROGS)
-
- all : $(PROGS)
-
-@@ -60,7 +60,7 @@
- rm -f *.o $(PROGS)
-
- install:
-- cp $(PROGS) $(XDIR)
-+ $(BSD_INSTALL_PROGRAM) $(PROGS) $(XDIR)
-
- sinstall:
- cp $(SPROGS) $(XDIR)
diff --git a/biology/fasta3/files/patch-comp_thr.c b/biology/fasta3/files/patch-comp_thr.c
deleted file mode 100644
index 24a0904c0d1c..000000000000
--- a/biology/fasta3/files/patch-comp_thr.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- comp_thr.c.orig Thu Aug 22 20:32:10 2002
-+++ comp_thr.c Thu Aug 22 20:32:25 2002
-@@ -16,7 +16,7 @@
- #include <time.h>
-
- #ifdef UNIX
--#if !defined(__NetBSD__) && !defined(MacOSX)
-+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(MacOSX)
- #include <values.h>
- #else
- #include <limits.h>
diff --git a/biology/fasta3/files/patch-compacc.c b/biology/fasta3/files/patch-compacc.c
deleted file mode 100644
index c6a493f81a31..000000000000
--- a/biology/fasta3/files/patch-compacc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- compacc.c.orig Thu Aug 22 20:30:30 2002
-+++ compacc.c Thu Aug 22 20:30:43 2002
-@@ -11,7 +11,7 @@
- #if defined(UNIX) || defined(MSDOS)
- #include <sys/types.h>
- #endif
--#if !defined(__MWERKS__) && !defined(MacOSX)
-+#if !defined(__FreeBSD__) && !defined(__MWERKS__) && !defined(MacOSX)
- #include <values.h>
- #else
- #include <limits.h>
diff --git a/biology/fasta3/files/patch-complib.c b/biology/fasta3/files/patch-complib.c
deleted file mode 100644
index d5f27bd708d0..000000000000
--- a/biology/fasta3/files/patch-complib.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- complib.c.orig Thu Aug 22 20:33:57 2002
-+++ complib.c Thu Aug 22 20:34:07 2002
-@@ -29,7 +29,7 @@
- #include <ctype.h>
- #include <time.h>
- #ifdef UNIX
--#if !defined(__NetBSD__) && !defined(MacOSX)
-+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(MacOSX)
- #include <values.h>
- #else
- #include <limits.h>
diff --git a/biology/fasta3/files/patch-scaleswn.c b/biology/fasta3/files/patch-scaleswn.c
deleted file mode 100644
index 3fd5f2023b63..000000000000
--- a/biology/fasta3/files/patch-scaleswn.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- scaleswn.c.orig Thu Aug 22 20:30:55 2002
-+++ scaleswn.c Thu Aug 22 20:31:06 2002
-@@ -26,7 +26,7 @@
- #include <math.h>
- #include <string.h>
-
--#if !defined(__MWERKS__) && !defined(MacOSX)
-+#if !defined(__FreeBSD__) && !defined(__MWERKS__) && !defined(MacOSX)
- #include <values.h>
- #else
- #include <limits.h> /* needed for LONG_MAX */
diff --git a/biology/fasta3/files/pkg-message.in b/biology/fasta3/files/pkg-message.in
new file mode 100644
index 000000000000..f43513546af4
--- /dev/null
+++ b/biology/fasta3/files/pkg-message.in
@@ -0,0 +1,16 @@
+=============================================================================
+
+ The FASTA3 package has been successfully installed.
+
+ A sample configuration file has been installed to
+ %%PREFIX%%/etc
+ as "fastlibs.sample". This may be renamed to "fastlibs" and edited
+ to suit the requirements of a particular site.
+
+ In order to use the FASTA3 programs, a user must set the environment
+ variable FASTLIBS to contain the full path of the FASTA3 configuration
+ file, e.g.:
+
+ set FASTLIBS to: "%%PREFIX%%/etc/fastlibs"
+
+==============================================================================
diff --git a/biology/fasta3/pkg-message b/biology/fasta3/pkg-message
deleted file mode 100644
index 4a6cc7e32515..000000000000
--- a/biology/fasta3/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
---------------------------------------------------------------------------
-
-The FASTA3 package has been successfully installed.
-
-NB: A sample configuration file has been installed to %%PREFIX%%/etc as
-"fastlibs.sample". This may be renamed to "fastlibs" and edited
-to suit the requirements of a particular site.
-
-In order to use the FASTA3 programs, a user must set the environment
-variable FASTLIBS to contain the full path of the FASTA3 configuration
-file, e.g.:
-
-- set FASTLIBS to: "%%PREFIX%%/etc/fastlibs"
-
---------------------------------------------------------------------------
diff --git a/biology/fasta3/pkg-plist b/biology/fasta3/pkg-plist
index 6e00e86ccfef..c50d96d66a18 100644
--- a/biology/fasta3/pkg-plist
+++ b/biology/fasta3/pkg-plist
@@ -1,11 +1,41 @@
-%%PORTDOCS%%%%DOCSDIR%%/00README.1st
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+bin/fasta34
+bin/prss34_t
+bin/tfastf34_t
+bin/fastf34_t
+bin/fastm34_t
+bin/tfasts34_t
+bin/tfasty34_t
+bin/fasty34_t
+bin/tfastx34_t
+bin/fastx34_t
+bin/tfasta34_t
+bin/fasts34_t
+bin/fasta34_t
+bin/ssearch34_t
+bin/tfastf34
+bin/fastf34
+bin/prfx34
+bin/prss34
+bin/tfastm34
+bin/fastm34
+bin/tfasts34
+bin/tfasty34
+bin/fasty34
+bin/tfastx34
+bin/fastx34
+bin/fasts34
+bin/tfasta34
+bin/ssearch34
+bin/prfx34_t
+etc/fastlibs.sample
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/fasta3x.doc
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/FASTA_LIST
%%PORTDOCS%%%%DOCSDIR%%/fasta3x.me
+%%PORTDOCS%%%%DOCSDIR%%/fasta3x.doc
+%%PORTDOCS%%%%DOCSDIR%%/fasta20.doc
+%%PORTDOCS%%%%DOCSDIR%%/fasta_func.doc
%%PORTDOCS%%%%DOCSDIR%%/readme.mpi_3.3
-%%PORTDOCS%%%%DOCSDIR%%/readme.pvm_2.0
-%%PORTDOCS%%%%DOCSDIR%%/readme.pvm_3.0
%%PORTDOCS%%%%DOCSDIR%%/readme.pvm_3.2
%%PORTDOCS%%%%DOCSDIR%%/readme.pvm_3.3
%%PORTDOCS%%%%DOCSDIR%%/readme.pvm_3.4
@@ -16,30 +46,57 @@
%%PORTDOCS%%%%DOCSDIR%%/readme.v31t1
%%PORTDOCS%%%%DOCSDIR%%/readme.v32t0
%%PORTDOCS%%%%DOCSDIR%%/readme.v33t0
+%%PORTDOCS%%%%DOCSDIR%%/readme.v34t0
%%PORTDOCS%%%%DOCSDIR%%/readme.w32
-bin/fasta3
-bin/fasta3_t
-bin/fastf3
-bin/fastf3_t
-bin/fasts3
-bin/fasts3_t
-bin/fastx3
-bin/fastx3_t
-bin/fasty3
-bin/fasty3_t
-bin/map_db
-bin/prss3
-bin/ssearch3
-bin/ssearch3_t
-bin/tfasta3
-bin/tfasta3_t
-bin/tfastf3
-bin/tfastf3_t
-bin/tfasts3
-bin/tfasts3_t
-bin/tfastx3
-bin/tfastx3_t
-bin/tfasty3
-bin/tfasty3_t
-etc/fastlibs.sample
+%%PORTDOCS%%%%DOCSDIR%%/fasta.defaults
+%%EXAMPLESDIR%%/egmsmg.aa
+%%EXAMPLESDIR%%/gtm1_human.aa
+%%EXAMPLESDIR%%/gtt1_drome.aa
+%%EXAMPLESDIR%%/h10_human.aa
+%%EXAMPLESDIR%%/hahu.aa
+%%EXAMPLESDIR%%/lcbo.aa
+%%EXAMPLESDIR%%/m1r.aa
+%%EXAMPLESDIR%%/m2.aa
+%%EXAMPLESDIR%%/mchu.aa
+%%EXAMPLESDIR%%/mgstm1.aa
+%%EXAMPLESDIR%%/ms1.aa
+%%EXAMPLESDIR%%/musplfm.aa
+%%EXAMPLESDIR%%/mwkw.aa
+%%EXAMPLESDIR%%/mwrtc1.aa
+%%EXAMPLESDIR%%/n0.aa
+%%EXAMPLESDIR%%/n1.aa
+%%EXAMPLESDIR%%/n2.aa
+%%EXAMPLESDIR%%/n2s.aa
+%%EXAMPLESDIR%%/n2t.aa
+%%EXAMPLESDIR%%/ngt.aa
+%%EXAMPLESDIR%%/ngts.aa
+%%EXAMPLESDIR%%/oohu.aa
+%%EXAMPLESDIR%%/prio_atepa.aa
+%%EXAMPLESDIR%%/qrhuld.aa
+%%EXAMPLESDIR%%/xurt8c.aa
+%%EXAMPLESDIR%%/xurtg.aa
+%%EXAMPLESDIR%%/mgstm1.lc
+%%EXAMPLESDIR%%/xurt8c.lc
+%%EXAMPLESDIR%%/bovgh.seq
+%%EXAMPLESDIR%%/bovprl.seq
+%%EXAMPLESDIR%%/gst.seq
+%%EXAMPLESDIR%%/hsgstm1b.seq
+%%EXAMPLESDIR%%/humgstd.seq
+%%EXAMPLESDIR%%/mgstm1.seq
+%%EXAMPLESDIR%%/mgtt2_x.seq
+%%DATADIR%%/blosum45.mat
+%%DATADIR%%/blosum50.mat
+%%DATADIR%%/blosum62.mat
+%%DATADIR%%/blosum80.mat
+%%DATADIR%%/dna.mat
+%%DATADIR%%/idn_aa.mat
+%%DATADIR%%/md_10.mat
+%%DATADIR%%/md_20.mat
+%%DATADIR%%/md_40.mat
+%%DATADIR%%/pam120.mat
+%%DATADIR%%/pam250.mat
+%%DATADIR%%/rna.mat
+%%DATADIR%%/vtml160.mat
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%