aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/nmap/Makefile19
-rw-r--r--security/nmap/distinfo2
-rw-r--r--security/nmap/pkg-plist32
3 files changed, 48 insertions, 5 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 885891a4d9b5..e3510752f393 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -3,11 +3,15 @@
PORTNAME= nmap
DISTVERSION= 6.40
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= ohauer
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-r${PATCHREV}.diff.bz2
+
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Port scanning utility for large networks
@@ -19,9 +23,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2 dos2unix
GNU_CONFIGURE= yes
+DOS2UNIX_FILES= nselib/data/packetdecoders.lua
+
+# Upstream revision r32810: nselib, scripts
+PATCHREV= 32810
OPTIONS_SUB= yes
OPTIONS_DEFINE= DOCS IPV6 SSL
@@ -70,9 +77,13 @@ pre-patch:
post-configure:
@${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|" ${WRKSRC}/Makefile
+pre-install:
+ ${FIND} ${WRKSRC} -type f \( -name \*.orig -o -name \*.bak \) -delete
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
# gcc from ports is in use
.if defined(NDCC)
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index ddd665d6dada..11e768fcdb72 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,2 +1,4 @@
SHA256 (nmap-6.40.tar.bz2) = 491f77d8b3fb3bb38ba4e3850011fe6fb43bbe197f9382b88cb59fa4e8f7a401
SIZE (nmap-6.40.tar.bz2) = 7871636
+SHA256 (nmap-6.40-r32810.diff.bz2) = 262ca2dc6a09e2388199d549cce8dd98ce13e3ce66fa17519ab582e4cdeba105
+SIZE (nmap-6.40-r32810.diff.bz2) = 1305713
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index da918aa945a2..75aebc834b69 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -44,9 +44,11 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/comm.lua
%%DATADIR%%/nselib/creds.lua
%%DATADIR%%/nselib/cvs.lua
+%%DATADIR%%/nselib/data/dns-srv-names
%%DATADIR%%/nselib/data/drupal-modules.lst
%%DATADIR%%/nselib/data/favicon-db
%%DATADIR%%/nselib/data/http-default-accounts-fingerprints.lua
+%%DATADIR%%/nselib/data/http-devframework-fingerprints.lua
%%DATADIR%%/nselib/data/http-fingerprints.lua
%%DATADIR%%/nselib/data/http-folders.txt
%%DATADIR%%/nselib/data/http-sql-errors.lst
@@ -92,6 +94,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/drda.lua
%%DATADIR%%/nselib/eap.lua
%%DATADIR%%/nselib/eigrp.lua
+%%DATADIR%%/nselib/formulas.lua
%%DATADIR%%/nselib/ftp.lua
%%DATADIR%%/nselib/giop.lua
%%DATADIR%%/nselib/gps.lua
@@ -157,7 +160,10 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/tab.lua
%%DATADIR%%/nselib/target.lua
%%DATADIR%%/nselib/tftp.lua
+%%DATADIR%%/nselib/tls.lua
%%DATADIR%%/nselib/tns.lua
+%%DATADIR%%/nselib/unicode.lua
+%%DATADIR%%/nselib/unittest.lua
%%DATADIR%%/nselib/unpwdb.lua
%%DATADIR%%/nselib/upnp.lua
%%DATADIR%%/nselib/url.lua
@@ -180,6 +186,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/ajp-headers.nse
%%DATADIR%%/scripts/ajp-methods.nse
%%DATADIR%%/scripts/ajp-request.nse
+%%DATADIR%%/scripts/allseeingeye-info.nse
%%DATADIR%%/scripts/amqp-info.nse
%%DATADIR%%/scripts/asn-query.nse
%%DATADIR%%/scripts/auth-owners.nse
@@ -276,6 +283,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/firewalk.nse
%%DATADIR%%/scripts/firewall-bypass.nse
%%DATADIR%%/scripts/flume-master-info.nse
+%%DATADIR%%/scripts/freelancer-info.nse
%%DATADIR%%/scripts/ftp-anon.nse
%%DATADIR%%/scripts/ftp-bounce.nse
%%DATADIR%%/scripts/ftp-brute.nse
@@ -315,15 +323,21 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-comments-displayer.nse
%%DATADIR%%/scripts/http-config-backup.nse
%%DATADIR%%/scripts/http-cors.nse
+%%DATADIR%%/scripts/http-csrf.nse
%%DATADIR%%/scripts/http-date.nse
%%DATADIR%%/scripts/http-default-accounts.nse
+%%DATADIR%%/scripts/http-devframework.nse
+%%DATADIR%%/scripts/http-dlink-backdoor.nse
+%%DATADIR%%/scripts/http-dombased-xss.nse
%%DATADIR%%/scripts/http-domino-enum-passwords.nse
%%DATADIR%%/scripts/http-drupal-enum-users.nse
%%DATADIR%%/scripts/http-drupal-modules.nse
%%DATADIR%%/scripts/http-email-harvest.nse
%%DATADIR%%/scripts/http-enum.nse
+%%DATADIR%%/scripts/http-errors.nse
%%DATADIR%%/scripts/http-exif-spider.nse
%%DATADIR%%/scripts/http-favicon.nse
+%%DATADIR%%/scripts/http-feed.nse
%%DATADIR%%/scripts/http-fileupload-exploiter.nse
%%DATADIR%%/scripts/http-form-brute.nse
%%DATADIR%%/scripts/http-form-fuzzer.nse
@@ -337,6 +351,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-huawei-hg5xx-vuln.nse
%%DATADIR%%/scripts/http-icloud-findmyiphone.nse
%%DATADIR%%/scripts/http-icloud-sendmsg.nse
+%%DATADIR%%/scripts/http-iis-short-name-brute.nse
%%DATADIR%%/scripts/http-iis-webdav-vuln.nse
%%DATADIR%%/scripts/http-joomla-brute.nse
%%DATADIR%%/scripts/http-litespeed-sourcecode-download.nse
@@ -344,6 +359,8 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-malware-host.nse
%%DATADIR%%/scripts/http-method-tamper.nse
%%DATADIR%%/scripts/http-methods.nse
+%%DATADIR%%/scripts/http-mobileversion-checker.nse
+%%DATADIR%%/scripts/http-ntlm-info.nse
%%DATADIR%%/scripts/http-open-proxy.nse
%%DATADIR%%/scripts/http-open-redirect.nse
%%DATADIR%%/scripts/http-passwd.nse
@@ -353,10 +370,12 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-proxy-brute.nse
%%DATADIR%%/scripts/http-put.nse
%%DATADIR%%/scripts/http-qnap-nas-info.nse
+%%DATADIR%%/scripts/http-referer-checker.nse
%%DATADIR%%/scripts/http-rfi-spider.nse
%%DATADIR%%/scripts/http-robots.txt.nse
%%DATADIR%%/scripts/http-robtex-reverse-ip.nse
%%DATADIR%%/scripts/http-robtex-shared-ns.nse
+%%DATADIR%%/scripts/http-server-header.nse
%%DATADIR%%/scripts/http-sitemap-generator.nse
%%DATADIR%%/scripts/http-slowloris-check.nse
%%DATADIR%%/scripts/http-slowloris.nse
@@ -367,6 +386,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-trace.nse
%%DATADIR%%/scripts/http-traceroute.nse
%%DATADIR%%/scripts/http-unsafe-output-escaping.nse
+%%DATADIR%%/scripts/http-useragent-tester.nse
%%DATADIR%%/scripts/http-userdir-enum.nse
%%DATADIR%%/scripts/http-vhosts.nse
%%DATADIR%%/scripts/http-virustotal.nse
@@ -379,11 +399,13 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-vuln-cve2011-3368.nse
%%DATADIR%%/scripts/http-vuln-cve2012-1823.nse
%%DATADIR%%/scripts/http-vuln-cve2013-0156.nse
+%%DATADIR%%/scripts/http-vuln-zimbra-lfi.nse
%%DATADIR%%/scripts/http-waf-detect.nse
%%DATADIR%%/scripts/http-waf-fingerprint.nse
%%DATADIR%%/scripts/http-wordpress-brute.nse
%%DATADIR%%/scripts/http-wordpress-enum.nse
%%DATADIR%%/scripts/http-wordpress-plugins.nse
+%%DATADIR%%/scripts/http-xssed.nse
%%DATADIR%%/scripts/iax2-brute.nse
%%DATADIR%%/scripts/iax2-version.nse
%%DATADIR%%/scripts/icap-info.nse
@@ -498,7 +520,9 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/pop3-brute.nse
%%DATADIR%%/scripts/pop3-capabilities.nse
%%DATADIR%%/scripts/pptp-version.nse
+%%DATADIR%%/scripts/qconn-exec.nse
%%DATADIR%%/scripts/qscan.nse
+%%DATADIR%%/scripts/quake1-info.nse
%%DATADIR%%/scripts/quake3-info.nse
%%DATADIR%%/scripts/quake3-master-getservers.nse
%%DATADIR%%/scripts/rdp-enum-encryption.nse
@@ -509,6 +533,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/resolveall.nse
%%DATADIR%%/scripts/reverse-index.nse
%%DATADIR%%/scripts/rexec-brute.nse
+%%DATADIR%%/scripts/rfc868-time.nse
%%DATADIR%%/scripts/riak-http-info.nse
%%DATADIR%%/scripts/rlogin-brute.nse
%%DATADIR%%/scripts/rmi-dumpregistry.nse
@@ -579,8 +604,10 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/ssl-date.nse
%%DATADIR%%/scripts/ssl-enum-ciphers.nse
%%DATADIR%%/scripts/ssl-google-cert-catalog.nse
+%%DATADIR%%/scripts/ssl-heartbleed.nse
%%DATADIR%%/scripts/ssl-known-key.nse
%%DATADIR%%/scripts/sslv2.nse
+%%DATADIR%%/scripts/sstp-discover.nse
%%DATADIR%%/scripts/stun-info.nse
%%DATADIR%%/scripts/stun-version.nse
%%DATADIR%%/scripts/stuxnet-detect.nse
@@ -598,6 +625,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/tftp-enum.nse
%%DATADIR%%/scripts/tls-nextprotoneg.nse
%%DATADIR%%/scripts/traceroute-geolocation.nse
+%%DATADIR%%/scripts/unittest.nse
%%DATADIR%%/scripts/unusual-port.nse
%%DATADIR%%/scripts/upnp-info.nse
%%DATADIR%%/scripts/url-snarf.nse
@@ -609,7 +637,9 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/voldemort-info.nse
%%DATADIR%%/scripts/vuze-dht-info.nse
%%DATADIR%%/scripts/wdb-version.nse
-%%DATADIR%%/scripts/whois.nse
+%%DATADIR%%/scripts/weblogic-t3-info.nse
+%%DATADIR%%/scripts/whois-domain.nse
+%%DATADIR%%/scripts/whois-ip.nse
%%DATADIR%%/scripts/wsdd-discover.nse
%%DATADIR%%/scripts/x11-access.nse
%%DATADIR%%/scripts/xdmcp-discover.nse