aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/php4-cryptopp/Makefile3
-rw-r--r--www/php-dyn/Makefile2
-rw-r--r--www/php-screw/Makefile2
3 files changed, 6 insertions, 1 deletions
diff --git a/security/php4-cryptopp/Makefile b/security/php4-cryptopp/Makefile
index 5f26a64dc52f..7cbcc4a274ee 100644
--- a/security/php4-cryptopp/Makefile
+++ b/security/php4-cryptopp/Makefile
@@ -23,7 +23,8 @@ DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}
USE_PERL5= yes
USE_PHP= yes
USE_PHPEXT= yes
-USE_PHPIZE= yes
+BROKEN_WITH_PHP=5
+DEFAULT_PHP_VER=4
CONFIGURE_ARGS= --with-cryptopp
diff --git a/www/php-dyn/Makefile b/www/php-dyn/Makefile
index f9031cc7e038..2c82aee6196a 100644
--- a/www/php-dyn/Makefile
+++ b/www/php-dyn/Makefile
@@ -19,6 +19,8 @@ COMMENT= A PHP Extension to help debugging a PHP script
USE_PHP= yes
USE_PHPIZE= yes
WITH_PHP_MOD= yes
+BROKEN_WITH_PHP=5
+DEFAULT_PHP_VER=4
CONFIGURE_ARGS= --enable-php_dyn=shared
diff --git a/www/php-screw/Makefile b/www/php-screw/Makefile
index 7ef04de03dec..2ed9b53478f0 100644
--- a/www/php-screw/Makefile
+++ b/www/php-screw/Makefile
@@ -22,6 +22,8 @@ CRYPTKEY?= 11152, 368, 192, 1281, 62
USE_PHP= yes
USE_PHPIZE= yes
+BROKEN_WITH_PHP=5
+DEFAULT_PHP_VER=4
CONFIGURE_ARGS+=--enable-php_screw=shared