aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/sslh/Makefile1
-rw-r--r--net/sslh/files/sslh.in10
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/apache22.in13
-rw-r--r--www/cblog/Makefile1
-rw-r--r--www/cblog/files/cblog.in9
-rw-r--r--www/fcgiwrap/Makefile2
-rw-r--r--www/fcgiwrap/files/fcgiwrap.in9
-rw-r--r--www/shellinabox/Makefile1
-rw-r--r--www/shellinabox/files/shellinaboxd.in13
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid/files/squid.in9
-rw-r--r--www/squid31/Makefile1
-rw-r--r--www/squid31/files/squid.in9
-rw-r--r--www/squid32/Makefile2
-rw-r--r--www/squid32/files/squid.in9
16 files changed, 63 insertions, 30 deletions
diff --git a/net/sslh/Makefile b/net/sslh/Makefile
index b4368b644a52..4d97e4a9e906 100644
--- a/net/sslh/Makefile
+++ b/net/sslh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sslh
PORTVERSION= 1.13
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.rutschle.net/tech/
diff --git a/net/sslh/files/sslh.in b/net/sslh/files/sslh.in
index af6b70ae7caa..16afac2d4bcf 100644
--- a/net/sslh/files/sslh.in
+++ b/net/sslh/files/sslh.in
@@ -17,7 +17,6 @@
# sslh_mode="fork | select"
# fork: stable but slow performance
# select: new but high performance
-# sslh_fib="NONE"
# sslh_pidfile="/var/run/sslh.pid"
# sslh_ssltarget="localhost:443"
# sslh_sshtarget="localhost:22"
@@ -26,9 +25,13 @@
# sslh_uid="nobody"
# sslh_flags
-sslh_setfib() {
+sslh_precmd() {
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
sysctl net.fibs >/dev/null 2>&1 || return 0
+ sslh_fib=${sslh_fib:-"NONE"}
case "$sslh_fib" in
[Nn][Oo][Nn][Ee])
;;
@@ -43,14 +46,13 @@ sslh_setfib() {
name="sslh"
rcvar=sslh_enable
-start_precmd="sslh_setfib"
+start_precmd="sslh_precmd"
stop_postcmd="sslh_postcmd"
load_rc_config $name
sslh_enable=${sslh_enable:-"NO"}
sslh_mode=${sslh_mode:-"fork"}
-sslh_fib=${sslh_fib:-"NONE"}
sslh_listening=${sslh_listening:-"0.0.0.0:443"}
sslh_sshtarget=${sslh_sshtarget:-"localhost:22"}
sslh_ssltarget=${sslh_ssltarget:-"localhost:8443"}
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index bc784a7a589e..a3fef1c25e1d 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache22
PORTVERSION= 2.2.23
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/apache22.in b/www/apache22/files/apache22.in
index d2ed50ce07c9..b2ac27483605 100644
--- a/www/apache22/files/apache22.in
+++ b/www/apache22/files/apache22.in
@@ -47,7 +47,6 @@ envvars="%%PREFIX%%/sbin/envvars"
[ -z "$apache22limits_enable" ] && apache22limits_enable="NO"
[ -z "$apache22limits_args" ] && apache22limits_args="-e -C daemon"
[ -z "$apache22_http_accept_enable" ] && apache22_http_accept_enable="NO"
-[ -z "$apache22_fib" ] && apache22_fib="NO"
apache22_accf() {
@@ -174,10 +173,14 @@ apache22_precmd()
}
apache22_checkfib () {
- $SYSCTL net.fibs >/dev/null 2>&1
- ret=$?
- [ $ret -gt 0 ] && return 0
- if [ "x$apache22_fib" != "xNO" ]
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ $SYSCTL net.fibs >/dev/null 2>&1 || return 0
+
+ apache22_fib={apache22_fib:-"NONE"}
+ if [ "x$apache22_fib" != "xNONE" ]
then
command="/usr/sbin/setfib -F ${apache22_fib} ${command}"
else
diff --git a/www/cblog/Makefile b/www/cblog/Makefile
index ffbe9952c85a..383f0a11f940 100644
--- a/www/cblog/Makefile
+++ b/www/cblog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cblog
PORTVERSION= 0.1.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://files.etoilebsd.net/cblog/
diff --git a/www/cblog/files/cblog.in b/www/cblog/files/cblog.in
index 94accfc99908..785eaa86179e 100644
--- a/www/cblog/files/cblog.in
+++ b/www/cblog/files/cblog.in
@@ -13,7 +13,6 @@
# cblog_enable=YES
#
# You can fine tune others variables too:
-# cblog_fib="NONE"
# cblog_socket="unix:/var/run/cblog/cblog.sock"
# syntax can be :
# unix:/patch/to/socket
@@ -21,8 +20,13 @@
# Use cblog_user to run cblog as user
cblog_setfib() {
- sysctl net.fibs >/dev/null 2>&1 || return 0
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+
+ cblog_fib=${cblog_fib:-"NONE"}
case "$cblog_fib" in
[Nn][Oo][Nn][Ee])
;;
@@ -48,7 +52,6 @@ start_precmd="cblog_precmd"
load_rc_config $name
cblog_enable=${cblog_enable:-"NO"}
-cblog_fib=${cblog_fib:-"NONE"}
cblog_user=${cblog_user:-"root"}
cblog_socket=${cblog_socker:-"unix:/var/run/cblog/cblog.sock"}
diff --git a/www/fcgiwrap/Makefile b/www/fcgiwrap/Makefile
index ea084044b5e6..ed0ed5a56563 100644
--- a/www/fcgiwrap/Makefile
+++ b/www/fcgiwrap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fcgiwrap
PORTVERSION= 1.0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://cloud.github.com/downloads/gnosek/fcgiwrap/
diff --git a/www/fcgiwrap/files/fcgiwrap.in b/www/fcgiwrap/files/fcgiwrap.in
index c4466f164d55..9c7fa7a6c5be 100644
--- a/www/fcgiwrap/files/fcgiwrap.in
+++ b/www/fcgiwrap/files/fcgiwrap.in
@@ -13,7 +13,6 @@
# fcgiwrap_enable="YES"
#
# You can fine tune others variables too:
-# fcgiwrap_fib="NONE"
# fcgiwrap_socket="unix:/var/run/fcgiwrap.sock"
# this could also be:
# - tcp:[ipv4_addr]:port (for ipv4)
@@ -42,8 +41,13 @@ name="fcgiwrap"
rcvar=fcgiwrap_enable
fcgiwrap_setfib() {
- sysctl net.fibs >/dev/null 2>&1 || return 0
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+ fcgiwrap_fib=${fcgiwrap_fib:-"NONE"}
case "$fcgiwrap_fib" in
[Nn][Oo][Nn][Ee])
;;
@@ -80,7 +84,6 @@ load_rc_config $name
# These are just the defaults, they might get overriden for a specific profile.
fcgiwrap_enable=${fcgiwrap_enable:-"NO"}
-fcgiwrap_fib=${fcgiwrap_fib:-"NONE"}
fcgiwrap_user=${fcgiwrap_user:-"root"}
fcgiwrap_socket=${fcgiwrap_socket:-"unix:/var/run/fcgiwrap/fcgiwrap.sock"}
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index 09d0f8b9db73..7ef312c7afdb 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= shellinabox
PORTVERSION= 2.14
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
diff --git a/www/shellinabox/files/shellinaboxd.in b/www/shellinabox/files/shellinaboxd.in
index 1cff58c7ae9a..d1e8c4d9a4dd 100644
--- a/www/shellinabox/files/shellinaboxd.in
+++ b/www/shellinabox/files/shellinaboxd.in
@@ -14,7 +14,6 @@
# shellinaboxd_enable="YES"
#
# You can fine tune others variables too:
-# shellinaboxd_fib="NONE"
# shellinaboxd_pidfile="/var/run/shellinabox.pid"
# shellinaboxd_user="%%USERS%%"
# shellinaboxd_group="%%GROUPS%%"
@@ -24,9 +23,14 @@
# Example: shellinaboxd_certfile="/your/cert.pem"
# shellinaboxd_flags=
-shellinaboxd_setfib() {
- sysctl net.fibs >/dev/null 2>&1 || return 0
+shellinaboxd_precmd() {
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+
+ shellinaboxd_fib=${shellinaboxd_fib:-"NONE"}
case "$shellinaboxd_fib" in
[Nn][Oo][Nn][Ee])
;;
@@ -42,12 +46,11 @@ name="shellinaboxd"
rcvar=shellinaboxd_enable
command="%%PREFIX%%/bin/${name}"
-start_precmd="shellinaboxd_setfib"
+start_precmd="shellinaboxd_precmd"
load_rc_config $name
shellinaboxd_enable=${shellinaboxd_enable:-"NO"}
-shellinaboxd_fib=${shellinaboxd_fib:-"NONE"}
shellinaboxd_user=${shellinaboxd_user:-"%%USERS%%"}
shellinaboxd_group=${shellinaboxd_group:-"%%GROUPS%%"}
shellinaboxd_port=${shellinaboxd_port:-"4200"}
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 1171e7fe2e72..f87a8ea12a1d 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -77,7 +77,7 @@
PORTNAME= squid
PORTVERSION= 2.7.${SQUID_STABLE_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid/files/squid.in b/www/squid/files/squid.in
index 499f79de6eea..56654a9950fe 100644
--- a/www/squid/files/squid.in
+++ b/www/squid/files/squid.in
@@ -45,7 +45,13 @@ squid_checkrunning() {
}
squid_setfib() {
- sysctl net.fibs >/dev/null 2>&1 || return 0
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+
+ squid_fib=${squid_fib:-"NONE"}
if [ "x${squid_fib}" != "xNONE" ]; then
command="setfib -F ${squid_fib} ${command}"
else
@@ -76,7 +82,6 @@ load_rc_config ${name}
squid_chdir=${squid_chdir:-"/var/squid/logs"}
squid_conf=${squid_conf:-"%%PREFIX%%/etc/squid/squid.conf"}
squid_enable=${squid_enable:-"NO"}
-squid_fib=${squid_fib:-"NONE"}
squid_flags=${squid_flags-"-D"}
squid_pidfile=${squid_pidfile:-"/var/squid/logs/squid.pid"}
squid_user=${squid_user:-%%SQUID_UID%%}
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 7e2a1ae81750..de2236404d11 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -51,6 +51,7 @@
PORTNAME= squid
PORTVERSION= 3.1.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid31/files/squid.in b/www/squid31/files/squid.in
index a6e0b637107a..67f2008b0712 100644
--- a/www/squid31/files/squid.in
+++ b/www/squid31/files/squid.in
@@ -45,7 +45,13 @@ squid_checkrunning() {
}
squid_setfib() {
- sysctl net.fibs >/dev/null 2>&1 || return 0
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+
+ squid_fib=${squid_fib:-"NONE"}
if [ "x${squid_fib}" != "xNONE" ]; then
command="setfib -F ${squid_fib} ${command}"
else
@@ -76,7 +82,6 @@ load_rc_config ${name}
squid_chdir=${squid_chdir:-"/var/squid"}
squid_conf=${squid_conf:-"%%PREFIX%%/etc/squid/squid.conf"}
squid_enable=${squid_enable:-"NO"}
-squid_fib=${squid_fib:-"NONE"}
squid_pidfile=${squid_pidfile:-"/var/run/squid/squid.pid"}
squid_user=${squid_user:-%%SQUID_UID%%}
diff --git a/www/squid32/Makefile b/www/squid32/Makefile
index 73a338a10959..93ca7846e39e 100644
--- a/www/squid32/Makefile
+++ b/www/squid32/Makefile
@@ -37,7 +37,7 @@
PORTNAME= squid
PORTVERSION= 3.2.${SQUID_STABLE_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
diff --git a/www/squid32/files/squid.in b/www/squid32/files/squid.in
index 6565dfcbcc45..aff0418b0003 100644
--- a/www/squid32/files/squid.in
+++ b/www/squid32/files/squid.in
@@ -50,7 +50,6 @@ load_rc_config ${name}
: ${squid_chdir:=/var/squid}
: ${squid_conf:=%%PREFIX%%/etc/squid/squid.conf}
: ${squid_enable:=NO}
-: ${squid_fib:=NONE}
: ${squid_pidfile:=/var/run/squid/squid.pid}
: ${squid_user:=squid}
@@ -77,7 +76,13 @@ command_args="-f ${squid_conf}"
squid_setfib()
{
- sysctl net.fibs >/dev/null 2>&1 || return 0
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ ${SYSCTL} net.fibs >/dev/null 2>&1 || return 0
+
+ squid_fib=${squid_fib:-"NONE"}
if [ "x${squid_fib}" != "xNONE" ]; then
command="setfib -F ${squid_fib} ${command}"
else