aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/monitoring-plugins/Makefile2
-rw-r--r--net-mgmt/monitoring-plugins/files/patch-plugins-root_check__dhcp.c12
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c12
4 files changed, 26 insertions, 2 deletions
diff --git a/net-mgmt/monitoring-plugins/Makefile b/net-mgmt/monitoring-plugins/Makefile
index bb4e9f625b58..f4b0790cf8e1 100644
--- a/net-mgmt/monitoring-plugins/Makefile
+++ b/net-mgmt/monitoring-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monitoring-plugins
PORTVERSION= 2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-mgmt
MASTER_SITES= https://www.monitoring-plugins.org/download/ LOCAL/mat/${PORTNAME}
diff --git a/net-mgmt/monitoring-plugins/files/patch-plugins-root_check__dhcp.c b/net-mgmt/monitoring-plugins/files/patch-plugins-root_check__dhcp.c
new file mode 100644
index 000000000000..912b9922d846
--- /dev/null
+++ b/net-mgmt/monitoring-plugins/files/patch-plugins-root_check__dhcp.c
@@ -0,0 +1,12 @@
+--- plugins-root/check_dhcp.c.orig 2014-07-06 17:55:03 UTC
++++ plugins-root/check_dhcp.c
+@@ -323,7 +323,8 @@ int get_hardware_address(int sock,char *
+ #elif defined(__bsd__)
+ /* King 2004 see ACKNOWLEDGEMENTS */
+
+- int mib[6], len;
++ int mib[6];
++ size_t len;
+ char *buf;
+ unsigned char *ptr;
+ struct if_msghdr *ifm;
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 88c657ae3c65..2b9a2b841ca5 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.0.3
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
new file mode 100644
index 000000000000..4ee277ab73c9
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
@@ -0,0 +1,12 @@
+--- plugins-root/check_dhcp.c.orig 2014-06-26 16:17:12 UTC
++++ plugins-root/check_dhcp.c
+@@ -326,7 +326,8 @@ int get_hardware_address(int sock,char *
+ #elif defined(__bsd__)
+ /* King 2004 see ACKNOWLEDGEMENTS */
+
+- int mib[6], len;
++ int mib[6];
++ size_t len;
+ char *buf;
+ unsigned char *ptr;
+ struct if_msghdr *ifm;