aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/kbibtex/Makefile2
-rw-r--r--databases/kbibtex/files/patch-bibtexstring.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 5905f1d76f13..494673218e30 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kbibtex
PORTVERSION= 0.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases kde
MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/download/
diff --git a/databases/kbibtex/files/patch-bibtexstring.cpp b/databases/kbibtex/files/patch-bibtexstring.cpp
new file mode 100644
index 000000000000..25f83bc339be
--- /dev/null
+++ b/databases/kbibtex/files/patch-bibtexstring.cpp
@@ -0,0 +1,10 @@
+--- src/bibtexstring.cpp.orig Tue Nov 8 13:07:00 2005
++++ src/bibtexstring.cpp Tue Nov 8 13:07:40 2005
+@@ -112,6 +112,7 @@
+ else result.append( "\"" );
+
+ result.append( " }" );
++ return result;
+ }
+ break;
+ case BibTeXFile::formatXML: