aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED3
-rw-r--r--comms/Makefile1
-rw-r--r--comms/hso-kmod/Makefile96
-rw-r--r--comms/hso-kmod/distinfo4
-rw-r--r--comms/hso-kmod/files/HSO-NODEBUG-patch-Makefile11
-rw-r--r--comms/hso-kmod/files/HSOCTL-NODEBUG-patch-Makefile10
-rw-r--r--comms/hso-kmod/files/option-icon.conf.sample7
-rw-r--r--comms/hso-kmod/files/pkg-message.in20
-rw-r--r--comms/hso-kmod/pkg-descr13
-rw-r--r--comms/hso-kmod/pkg-plist8
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Mail-CClient/Makefile75
-rw-r--r--mail/p5-Mail-CClient/distinfo2
-rw-r--r--mail/p5-Mail-CClient/pkg-descr7
-rw-r--r--mail/p5-Mail-CClient/pkg-plist30
-rw-r--r--net/Makefile1
-rw-r--r--net/slbd/Makefile34
-rw-r--r--net/slbd/distinfo2
-rw-r--r--net/slbd/files/patch-Makefile32
-rw-r--r--net/slbd/pkg-descr5
20 files changed, 3 insertions, 359 deletions
diff --git a/MOVED b/MOVED
index 0ecb622ff879..bcd0a38ec11f 100644
--- a/MOVED
+++ b/MOVED
@@ -4844,3 +4844,6 @@ www/w3m-m17n|www/w3m|2013-08-22|Unified to www/w3m
www/w3m-m17n-img|www/w3m-img|2013-08-22|Unified to www/w3m-img
www/moodle22||2013-08-20|Has expired: Unmaintained upstream
security/sfs||2013-08-23|Has expired: Broken on FreeBSD 8 and newer
+mail/p5-Mail-CClient||2013-08-26|Has expired: Broken for more than 6 month
+net/slbd||2013-08-26|Has expired: Broken on FreeBSD 8 and newer
+comms/hso-kmod||2013-08-26|Has expired: Broken on FreeBSD 8 and newer
diff --git a/comms/Makefile b/comms/Makefile
index 6dced03e891f..ffa489b9d084 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -63,7 +63,6 @@
SUBDIR += hamlib
SUBDIR += hcidump
SUBDIR += hf
- SUBDIR += hso-kmod
SUBDIR += hylafax
SUBDIR += ib-kmod
SUBDIR += ibp
diff --git a/comms/hso-kmod/Makefile b/comms/hso-kmod/Makefile
deleted file mode 100644
index 772801c1bfe0..000000000000
--- a/comms/hso-kmod/Makefile
+++ /dev/null
@@ -1,96 +0,0 @@
-# New ports collection makefile for: hso-kmod
-# Date created: 12 May 2008
-# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= hso
-PORTVERSION= 20081023
-PORTREVISION= 3
-CATEGORIES= comms kld
-MASTER_SITES= http://www.shapeshifter.se/pub/hso/
-PKGNAMESUFFIX= -kmod
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-
-MAINTAINER= martymac@FreeBSD.org
-COMMENT= Driver for Option HSDPA modem
-
-LICENSE= BSD
-
-DEPRECATED= Broken on FreeBSD 8 and newer
-EXPIRATION_DATE=2013-08-24
-
-CONFLICTS= uhso-kmod-[0-9]*
-
-NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-
-OPTIONS_DEFINE= HSOCTL DEVD DEBUG
-OPTIONS_DEFAULT= HSOCTL DEVD
-
-HSOCTL_DESC= Build hsoctl tool
-
-SUB_FILES= pkg-message
-KMODDIR?= /boot/modules
-PLIST_SUB+= KMODDIR=${KMODDIR}
-MAKE_ENV+= KMODDIR=${KMODDIR}
-
-MAN4= hso.4
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 800063
-BROKEN= does not build with USB2, please try comms/uhso-kmod instead
-.endif
-
-.if ${PORT_OPTIONS:MHSOCTL}
-HSOCTL_VERSION= 20081023
-DISTFILES+= hsoctl-${HSOCTL_VERSION}${EXTRACT_SUFX}
-WRKSRC_HSOCTL= ${WRKDIR}/hsoctl-${HSOCTL_VERSION}
-PLIST_SUB+= PL_HSOCTL=""
-MAN1= hsoctl.1
-.else
-PLIST_SUB+= PL_HSOCTL="@comment "
-.endif
-.if ${PORT_OPTIONS:MDEVD}
-PLIST_SUB+= PL_DEVD=""
-.else
-PLIST_SUB+= PL_DEVD="@comment "
-.endif
-.if empty(PORT_OPTIONS:MDEBUG)
-EXTRA_PATCHES+= ${PATCHDIR}/HSO-NODEBUG-patch-Makefile
-.endif
-
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source files
-.elif ${OSVERSION} < 700055
-IGNORE= requires FreeBSD 7.0 or superior
-.endif
-
-post-patch:
-.if !empty(PORT_OPTIONS:MHSOCTL) && empty(PORT_OPTIONS:MDEBUG)
- @${PATCH} -d ${WRKSRC_HSOCTL} < ${PATCHDIR}/HSOCTL-NODEBUG-patch-Makefile
-.endif
-
-post-build:
-.if ${PORT_OPTIONS:MHSOCTL}
- @cd ${WRKSRC_HSOCTL} && ${SETENV} NO_MANCOMPRESS= ${MAKE} all
-.endif
-
-post-install:
- ${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
-.if ${PORT_OPTIONS:MHSOCTL}
- @cd ${WRKSRC_HSOCTL} && \
- ${SETENV} DESTDIR=${PREFIX}/ BINDIR=bin MANDIR=man/man NO_MANCOMPRESS= \
- ${MAKE} install
-.endif
-.if ${PORT_OPTIONS:MDEVD}
- ${MKDIR} ${PREFIX}/etc/devd
- ${INSTALL_DATA} ${FILESDIR}/option-icon.conf.sample ${PREFIX}/etc/devd/
- @if [ ! -f ${PREFIX}/etc/devd/option-icon.conf ]; then \
- ${CP} -p ${PREFIX}/etc/devd/option-icon.conf.sample ${PREFIX}/etc/devd/option-icon.conf; \
- fi
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/comms/hso-kmod/distinfo b/comms/hso-kmod/distinfo
deleted file mode 100644
index 84ae43f91647..000000000000
--- a/comms/hso-kmod/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (hso-20081023.tar.gz) = 8ab6cf4bc0208dbe76cdf41422b573afb811e6075c99e97f38f5377f47bc648c
-SIZE (hso-20081023.tar.gz) = 12326
-SHA256 (hsoctl-20081023.tar.gz) = fe20461852c72ed554c5f1cf7dd98f9dd2a5217fc4b4a2ca3e1e7ade301ba8fe
-SIZE (hsoctl-20081023.tar.gz) = 8360
diff --git a/comms/hso-kmod/files/HSO-NODEBUG-patch-Makefile b/comms/hso-kmod/files/HSO-NODEBUG-patch-Makefile
deleted file mode 100644
index 9cf82162c477..000000000000
--- a/comms/hso-kmod/files/HSO-NODEBUG-patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2008-05-14 14:18:19.880920578 +0200
-+++ Makefile 2008-05-14 14:18:29.051785451 +0200
-@@ -2,7 +2,7 @@
- S= ${.CURDIR}/../..
- .PATH: $S/dev/usb
-
--CFLAGS+= -DUSB_DEBUG=1 -DHSO_DEBUG=-1 -g
-+#CFLAGS+= -DUSB_DEBUG=1 -DHSO_DEBUG=-1 -g
- KMOD= hso
- SRCS= if_hso.c opt_usb.h device_if.h bus_if.h usbdevs.h
-
diff --git a/comms/hso-kmod/files/HSOCTL-NODEBUG-patch-Makefile b/comms/hso-kmod/files/HSOCTL-NODEBUG-patch-Makefile
deleted file mode 100644
index c87686f43e44..000000000000
--- a/comms/hso-kmod/files/HSOCTL-NODEBUG-patch-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig 2008-10-23 15:45:28.158855941 +0200
-+++ Makefile 2008-10-23 15:45:53.171672654 +0200
-@@ -1,6 +1,6 @@
- SRCS= hsoctl.c
- PROG= hsoctl
--CFLAGS+= -g
-+#CFLAGS+= -g
- LDFLAGS+= -lutil
- DESTDIR?= /usr/local
-
diff --git a/comms/hso-kmod/files/option-icon.conf.sample b/comms/hso-kmod/files/option-icon.conf.sample
deleted file mode 100644
index d32ba783b7ac..000000000000
--- a/comms/hso-kmod/files/option-icon.conf.sample
+++ /dev/null
@@ -1,7 +0,0 @@
-attach 100 {
-match "device-name" "umass[0-9]+";
-match "vendor" "0x0af0";
-match "product" "0x6911|0x6971|0x7251|0x7401|0x7011|0x7501";
-match "devclass" "0x00";
-action "sleep 1; /sbin/camcontrol cmd `/sbin/camcontrol devlist | /usr/bin/grep ZCOPTION | /usr/bin/awk '{match($11, /pass[0-9]+/); print substr($11, RSTART, RLENGTH) }'` -c '01 00 00 00 00 00' -i 1 i1 > /dev/null";
-};
diff --git a/comms/hso-kmod/files/pkg-message.in b/comms/hso-kmod/files/pkg-message.in
deleted file mode 100644
index 40fcc68195de..000000000000
--- a/comms/hso-kmod/files/pkg-message.in
+++ /dev/null
@@ -1,20 +0,0 @@
-
-===============================================================================
-
-This port has installed the hso kernel module.
-
-1) To load the kernel module at boot time,
-add the following line to /boot/loader.conf:
-
-hso_load="YES"
-
-2) If you have installed devd files, restart devd :
-/etc/rc.d/devd restart
-
-3) If you have built the hsoctl utility, use it to connect :
-e.g. : hsoctl -a bredband.tre.se -p 1234 hso0
-
-4) Enjoy !
-
-===============================================================================
-
diff --git a/comms/hso-kmod/pkg-descr b/comms/hso-kmod/pkg-descr
deleted file mode 100644
index d547a3691b3f..000000000000
--- a/comms/hso-kmod/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-FreeBSD driver for newer Option HSDPA USB dongles.
-
-The driver have been tested with the following devices
-
- * Option GlobeSurfer iCON 7.2 (2.4.6Hd firmware)
- * Option GlobeSurfer iCON 225
-
-Older cards should work just fine with ubsa(4) or any similar
-USB-over-serial driver.
-
-Note that this driver should be considered beta.
-
-WWW: http://www.shapeshifter.se/code/hso/
diff --git a/comms/hso-kmod/pkg-plist b/comms/hso-kmod/pkg-plist
deleted file mode 100644
index 38ad1e553d24..000000000000
--- a/comms/hso-kmod/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-%%PL_DEVD%%@unexec if cmp -s %D/etc/devd/option-icon.conf.sample %D/etc/devd/option-icon.conf; then rm -f %D/etc/devd/option-icon.conf; fi
-%%PL_DEVD%%etc/devd/option-icon.conf.sample
-%%PL_DEVD%%@exec if [ ! -f %D/etc/devd/option-icon.conf ]; then mkdir -p %B; cp -p %D/%F %B/option-icon.conf; fi
-%%PL_HSOCTL%%bin/hsoctl
-@cwd /boot/modules
-hso.ko
-@exec kldxref %D
-@unexec kldxref %D
diff --git a/mail/Makefile b/mail/Makefile
index c9fd877f05df..c37c79f9aa8d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -387,7 +387,6 @@
SUBDIR += p5-Mail-Box
SUBDIR += p5-Mail-Box-Parser-C
SUBDIR += p5-Mail-Bulkmail
- SUBDIR += p5-Mail-CClient
SUBDIR += p5-Mail-Cache
SUBDIR += p5-Mail-CheckUser
SUBDIR += p5-Mail-ClamAV
diff --git a/mail/p5-Mail-CClient/Makefile b/mail/p5-Mail-CClient/Makefile
deleted file mode 100644
index 1458adf85cae..000000000000
--- a/mail/p5-Mail-CClient/Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
-# Created by: Kelly Yancey <kbyanc@posi.net>
-# $FreeBSD$
-
-PORTNAME= Mail-CClient
-PORTVERSION= 1.12
-PORTREVISION= 1
-CATEGORIES= mail perl5
-MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:HDIAS
-PKGNAMEPREFIX= p5-
-DISTNAME= Mail-Cclient-${PORTVERSION}
-
-MAINTAINER= perl@FreeBSD.org
-COMMENT= Perl interface to the c-client mailbox API
-
-LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
-
-USES= perl5
-USE_PERL5= configure
-CONFIGURE_ARGS= --cclient_dir=${LOCALBASE} \
- --with-shared_cclient \
- --with-pam \
- --with-cclient-includes=${LOCALBASE}/include/c-client
-
-MAN3= Mail::Cclient.3
-
-DEPRECATED= Broken for more than 6 month
-EXPIRATION_DATE= 2013-08-24
-
-.if !defined(NOPORTDOCS)
-PORTDOCS= Changes FAQ README TODO
-EXAMPLES= copy.txt \
- fetch_body.pl \
- fetch_structure.pl \
- imap.txt \
- list_mailboxs.pl \
- mime.txt \
- rfc822_date.pl \
- rfc822_output.txt \
- rfc822_parse_adrlist.pl \
- rfc822_write_address.pl \
- search.txt \
- search_msg.txt \
- smtp_mail.pl \
- smtp_mail_append.txt \
- smtp_mail_mpart.pl \
- sort.txt \
- struct.txt \
- summ.txt \
- thread.txt \
- thread_test.pl \
- utf8_mime2text.pl
-
-post-install:
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Documentation installed in ${EXAMPLESDIR}."
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${PERL} -pi -e 's/-lc-client/-lc-client4/g;' \
- -e 's/"-lc"/"-L\$$CCLIENT_DIR\/lib "/g;' \
- -e 's/ -lpam_misc//g;' \
- ${WRKSRC}/Makefile.PL
-
-.if ${PERL_LEVEL} > 501400
-BROKEN= does not compile, no release since 2004
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-CClient/distinfo b/mail/p5-Mail-CClient/distinfo
deleted file mode 100644
index 15f2d07cdbae..000000000000
--- a/mail/p5-Mail-CClient/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (Mail-Cclient-1.12.tar.gz) = f288f3fbb229d811341be57910775ab9a49eabaaee2539b2b8b46534e6efbcd7
-SIZE (Mail-Cclient-1.12.tar.gz) = 77541
diff --git a/mail/p5-Mail-CClient/pkg-descr b/mail/p5-Mail-CClient/pkg-descr
deleted file mode 100644
index e6254b251607..000000000000
--- a/mail/p5-Mail-CClient/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-From the README:
- Mail::Cclient gives access to mailboxes in many different formats
- (including remote IMAP folders) via the c-client API. The c-client
- library is the core library used by Pine and the University of
- Washington IMAP daemon (written by Mark Crispin).
-
-WWW: http://search.cpan.org/dist/Mail-Cclient/
diff --git a/mail/p5-Mail-CClient/pkg-plist b/mail/p5-Mail-CClient/pkg-plist
deleted file mode 100644
index 042b31ed32a5..000000000000
--- a/mail/p5-Mail-CClient/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Mail/Cclient.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Mail/Cclient.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Cclient/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Cclient/Cclient.bs
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Cclient/Cclient.so
-%%PORTDOCS%%%%EXAMPLESDIR%%/copy.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/fetch_body.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/fetch_structure.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/imap.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/list_mailboxs.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/mime.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/rfc822_date.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/rfc822_output.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/rfc822_parse_adrlist.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/rfc822_write_address.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/search.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/search_msg.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/smtp_mail.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/smtp_mail_append.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/smtp_mail_mpart.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/sort.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/struct.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/summ.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/thread.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/thread_test.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/utf8_mime2text.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Cclient
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Mail
diff --git a/net/Makefile b/net/Makefile
index 981372f2973b..d410a5cdbf70 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1112,7 +1112,6 @@
SUBDIR += skyfish
SUBDIR += skystar2
SUBDIR += sl2tps
- SUBDIR += slbd
SUBDIR += slirp
SUBDIR += slurm
SUBDIR += smb4k-kde4
diff --git a/net/slbd/Makefile b/net/slbd/Makefile
deleted file mode 100644
index f57b336dc03f..000000000000
--- a/net/slbd/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# Created by: Janos Mohacsi <janos.mohacsi@bsd.hu>
-# $FreeBSD$
-
-PORTNAME= slbd
-PORTVERSION= 1.3
-CATEGORIES= net sysutils
-MASTER_SITES= SF
-
-MAINTAINER= jmohacsi@bsd.hu
-COMMENT= Server load balancing daemon for *BSD pf
-
-DEPRECATED= Broken on FreeBSD 8 and newer
-EXPIRATION_DATE=2013-08-24
-
-PLIST_FILES= sbin/slbd etc/slbdcap-sample
-PORTDOCS= configfile.txt
-
-post-patch:
- @${REINPLACE_CMD} -e "s;%%PREFIX%%;${PREFIX};g" \
- ${WRKSRC}/Makefile
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800502
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net/slbd/distinfo b/net/slbd/distinfo
deleted file mode 100644
index ee11047515dc..000000000000
--- a/net/slbd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (slbd-1.3.tar.gz) = 661e60fcd6191aa3d8510eefc4812dadd0268151aa2611ea7d566cacffcbf547
-SIZE (slbd-1.3.tar.gz) = 20110
diff --git a/net/slbd/files/patch-Makefile b/net/slbd/files/patch-Makefile
deleted file mode 100644
index b39d62521059..000000000000
--- a/net/slbd/files/patch-Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
-@@ -14,15 +14,11 @@
- #SUBDIR=tests
- PROG=slbd
- MAN=
--PREFIX=/usr/local
-+PREFIX=%%PREFIX%%
- BINDIR=sbin
- CONFDIR=etc
-
--.if exists(${PREFIX}/${CONFDIR}/slbdcap)
--CONFFILE=$(PREFIX)/$(CONFDIR)/slbdcap.new
--.else
--CONFFILE=$(PREFIX)/$(CONFDIR)/slbdcap
--.endif
-+CONFFILE=$(PREFIX)/$(CONFDIR)/slbdcap-sample
-
-
- .c.o:
-@@ -47,7 +43,7 @@
- install-slbd:
- $(INSTALL) $(PROG) $(PREFIX)/$(BINDIR)/
- #mkdir -p $(PREFIX)/$(CONFDIR)
-- #cp conf/slbdcap $(CONFFILE)
-+ $(INSTALL) conf/slbdcap $(CONFFILE)
-
- config-clean:
- rm -f config.o config_test config
diff --git a/net/slbd/pkg-descr b/net/slbd/pkg-descr
deleted file mode 100644
index a5cdf5d09176..000000000000
--- a/net/slbd/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-The slbd project aims to produce stable, production-quality code to monitor
-web and other TCP-based servers, allowing for server load balancing (SLB)
-functionality through *BSD's PF packet filter.
-
-WWW: http://slbd.sourceforge.net/