aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/iconv.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/iconv.mk')
-rw-r--r--Mk/Uses/iconv.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
index e55fcffe8cc5..8561e51c666b 100644
--- a/Mk/Uses/iconv.mk
+++ b/Mk/Uses/iconv.mk
@@ -6,12 +6,12 @@
# wchar_t (port uses "WCHAR_T" extension),
# translit (port uses "//TRANSLIT" extension)
#
-# MAINTAINER: portmgr@FreeBSD.org
+# MAINTAINER: desktop@FreeBSD.org
.if !defined(_INCLUDE_USES_ICONV_MK)
_INCLUDE_USES_ICONV_MK= yes
-.if !exists(/usr/include/iconv.h) || ${iconv_ARGS:Mwchar_t} || ${iconv_ARGS:Mtranslit}
+. if !exists(/usr/include/iconv.h) || ${iconv_ARGS:Mwchar_t} || ${iconv_ARGS:Mtranslit}
ICONV_CMD= ${LOCALBASE}/bin/iconv
ICONV_LIB= -liconv
@@ -21,15 +21,15 @@ ICONV_CONFIGURE_BASE= --with-libiconv=${LOCALBASE}
ICONV_INCLUDE_PATH= ${LOCALBASE}/include
ICONV_LIB_PATH= ${LOCALBASE}/lib/libiconv.so
-.if ${iconv_ARGS:Mbuild}
+. if ${iconv_ARGS:Mbuild}
BUILD_DEPENDS+= ${ICONV_CMD}:converters/libiconv
-.elif ${iconv_ARGS:Mpatch}
+. elif ${iconv_ARGS:Mpatch}
PATCH_DEPENDS+= ${ICONV_CMD}:converters/libiconv
-.else
+. else
LIB_DEPENDS+= libiconv.so:converters/libiconv
-.endif
+. endif
-.else
+. else
ICONV_CMD= /usr/bin/iconv
ICONV_LIB=
@@ -39,10 +39,10 @@ ICONV_CONFIGURE_BASE=
ICONV_INCLUDE_PATH= /usr/include
ICONV_LIB_PATH= /usr/lib/libc.so
-.if exists(${LOCALBASE}/include/iconv.h)
+. if exists(${LOCALBASE}/include/iconv.h)
# Check that libiconv iconv.h is recent enough for LIBICONV_PLUG to work.
BUILD_DEPENDS+= libiconv>=1.14_11:converters/libiconv
-.endif
+. endif
# LIBICONV_PLUG makes libiconv iconv.h act like libc iconv.h.
CPPFLAGS+= -DLIBICONV_PLUG
@@ -50,7 +50,7 @@ CFLAGS+= -DLIBICONV_PLUG
CXXFLAGS+= -DLIBICONV_PLUG
OBJCFLAGS+= -DLIBICONV_PLUG
-.endif
+. endif
# These are the most common names for the iconv-related variables found in
# CMake-based ports. We set them here via CMAKE_ARGS to make sure that the best