aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/motif.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/motif.mk')
-rw-r--r--Mk/Uses/motif.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/Mk/Uses/motif.mk b/Mk/Uses/motif.mk
index 8828ceb4c4d1..a64cdbb98336 100644
--- a/Mk/Uses/motif.mk
+++ b/Mk/Uses/motif.mk
@@ -6,31 +6,31 @@
# If WANT_LESSTIF is defined in user make.conf then lesstif will be used
# instead of open-motif
#
-# MAINTAINER: portmgr@FreeBSD.org
+# MAINTAINER: ports@FreeBSD.org
.if !defined(_INCLUDE_USES_MOTIF_MK)
_INCLUDE_USES_MOTIF_MK= yes
-.if !empty(motif_ARGS)
+. if !empty(motif_ARGS)
IGNORE= USES=motif takes no arguments
-.endif
+. endif
-.if defined(WANT_LESSTIF)
+. if defined(WANT_LESSTIF)
LIB_DEPENDS+= libXm.so:x11-toolkits/lesstif
-.else
+. elif defined(WANT_OPEN_MOTIF_DEVEL)
+USE_XORG+= xpm
+LIB_DEPENDS+= libXm.so.4:x11-toolkits/open-motif-devel
+. else
USE_XORG+= xpm
LIB_DEPENDS+= libXm.so.4:x11-toolkits/open-motif
-.endif
+. endif
MOTIFLIB?= -L${LOCALBASE}/lib -lXm
MAKE_ENV+= MOTIFLIB="${MOTIFLIB}"
# We only need to include xorg.mk if we want USE_XORG modules
-# USES+=xorg does not provide any functionality, it just silences an error
-# message about USES=xorg not being set
-.if defined(USE_XORG) && !empty(USE_XORG)
-USES+= xorg
+. if defined(USE_XORG) && !empty(USE_XORG)
.include "${USESDIR}/xorg.mk"
-.endif
+. endif
.endif