aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/xorg-cat.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/xorg-cat.mk')
-rw-r--r--Mk/Uses/xorg-cat.mk21
1 files changed, 2 insertions, 19 deletions
diff --git a/Mk/Uses/xorg-cat.mk b/Mk/Uses/xorg-cat.mk
index 1134ff977b94..0853fd6b3e3c 100644
--- a/Mk/Uses/xorg-cat.mk
+++ b/Mk/Uses/xorg-cat.mk
@@ -17,7 +17,6 @@
# * proto install .pc file, needs pathfix, most only needed at
# build time.
# * util no particular notes
-# * xserver xorg x servers
#
# These categories has to match upstream categories. Don't invent
# your own.
@@ -27,7 +26,7 @@
# * meson (experimental)
#
#
-# By defining USE_GITLAB and GL_COMMIT, it is possible to pull code straight
+# By defining USE_GITLAB and GL_TAGNAME, it is possible to pull code straight
# from the freedesktop.org gitlab, instead of official release tarballs.
#
#.MAINTAINER: x11@FreeBSD.org
@@ -35,7 +34,7 @@
.if !defined(_INCLUDE_USES_XORG_CAT_MK)
_INCLUDE_USES_XORG_CAT_MK=yes
-_XORG_CATEGORIES= app data doc driver font lib proto util xserver
+_XORG_CATEGORIES= app data doc driver font lib proto util
_XORG_BUILDSYSTEMS= autotools meson
_XORG_CAT= # empty
@@ -76,7 +75,6 @@ EXTRACT_SUFX?= .tar.bz2
DIST_SUBDIR= xorg/${_XORG_CAT}
. if ${_XORG_BUILDSYS} == meson
-IGNORE= meson build not supported yet
.include "${USESDIR}/meson.mk"
. elif ${_XORG_BUILDSYS} == autotools
GNU_CONFIGURE= yes
@@ -163,21 +161,6 @@ CONFIGURE_ARGS+=--enable-malloc0returnsnull
. elif ${_XORG_CAT} == proto
.include "${USESDIR}/pathfix.mk"
-. elif ${_XORG_CAT} == xserver
-DISTNAME?= xorg-server-${PORTVERSION}
-CFLAGS+= -Werror=uninitialized
-.include "${USESDIR}/pathfix.mk"
-. if ${_XORG_BUILDSYS} == meson
-# put meson stuff here
-. else
-CONFIGURE_ARGS+= --with-xkb-path=${LOCALBASE}/share/X11/xkb \
- --with-fontrootdir=${LOCALBASE}/share/fonts
-libtool_ARGS?= # empty
-.include "${USESDIR}/libtool.mk"
-. endif
-LIB_PC_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri
-USE_XORG+= fontutil
-
. endif # ${_XORG_CAT} == <category>
# We only need to include xorg.mk if we want USE_XORG modules