aboutsummaryrefslogtreecommitdiff
path: root/accessibility/at-spi2-atk
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/at-spi2-atk')
-rw-r--r--accessibility/at-spi2-atk/Makefile30
-rw-r--r--accessibility/at-spi2-atk/distinfo3
-rw-r--r--accessibility/at-spi2-atk/pkg-descr9
-rw-r--r--accessibility/at-spi2-atk/pkg-plist6
4 files changed, 48 insertions, 0 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
new file mode 100644
index 000000000000..d498feba7cc6
--- /dev/null
+++ b/accessibility/at-spi2-atk/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: at-spi
+# Date Created: 12 April 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.6 2010/04/01 12:23:26 kwm Exp $
+#
+
+PORTNAME= at-spi2-atk
+PORTVERSION= 0.1.8
+CATEGORIES= accessibility x11-toolkits
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Assisted Technology Provider module for GTK+
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomehier intlhack gtk20 libxml2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/accessibility/at-spi2-atk/distinfo b/accessibility/at-spi2-atk/distinfo
new file mode 100644
index 000000000000..6c0a2ff5560e
--- /dev/null
+++ b/accessibility/at-spi2-atk/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/at-spi2-atk-0.1.8.tar.bz2) = dbf92538b4e83bcd0a5f42adb9143411
+SHA256 (gnome2/at-spi2-atk-0.1.8.tar.bz2) = 7ccfb43ec166814aa3daf0bf1b894d07b766d05c30860ef3db759f2dab72f2eb
+SIZE (gnome2/at-spi2-atk-0.1.8.tar.bz2) = 292459
diff --git a/accessibility/at-spi2-atk/pkg-descr b/accessibility/at-spi2-atk/pkg-descr
new file mode 100644
index 000000000000..1524ccfd79ff
--- /dev/null
+++ b/accessibility/at-spi2-atk/pkg-descr
@@ -0,0 +1,9 @@
+This is the Gnome Accessibility Project's Assistive Technology
+Service Provider Interface. It allows accessibility applications
+and assistive technologies to announce their respective existence
+to each other.
+
+This port contains the GTK+ module needed to interface with the SPI
+framework.
+
+WWW: http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
diff --git a/accessibility/at-spi2-atk/pkg-plist b/accessibility/at-spi2-atk/pkg-plist
new file mode 100644
index 000000000000..fb9bd01547e3
--- /dev/null
+++ b/accessibility/at-spi2-atk/pkg-plist
@@ -0,0 +1,6 @@
+lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.a
+lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.la
+lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.so
+share/gnome/autostart/atk-bridge.desktop
+@dirrm lib/gtk-2.0/modules/at-spi-dbus/modules
+@dirrm lib/gtk-2.0/modules/at-spi-dbus