aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/gail/Makefile')
-rw-r--r--accessibility/gail/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/accessibility/gail/Makefile b/accessibility/gail/Makefile
index 48007940b9a7..c3515535376d 100644
--- a/accessibility/gail/Makefile
+++ b/accessibility/gail/Makefile
@@ -6,29 +6,27 @@
#
PORTNAME= gail
-PORTVERSION= 0.17
+PORTVERSION= 1.2.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.17
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas
+LIB_DEPENDS= gnomecanvas-2.200:${PORTSDIR}/graphics/libgnomecanvas
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
-
.include <bsd.port.mk>