aboutsummaryrefslogtreecommitdiff
path: root/arabic/ae_fonts_mono/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arabic/ae_fonts_mono/Makefile')
-rw-r--r--arabic/ae_fonts_mono/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/arabic/ae_fonts_mono/Makefile b/arabic/ae_fonts_mono/Makefile
new file mode 100644
index 000000000000..8032e790d5e2
--- /dev/null
+++ b/arabic/ae_fonts_mono/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ae_fonts_mono
+# Date created: August 22, 2003
+# Whom: Samy Al Bahra <samy@kerneled.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ae_fonts_mono
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= arabeyes
+DISTNAME= ae_fonts_mono
+
+MAINTAINER= samy@kerneled.com
+COMMENT= A collection of PCF fonts that include Arabic glyphs
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.elif ${XFREE86_VERSION} == 3
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86
+.endif
+
+do-build:
+ @mkfontdir ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/X11/fonts/ae_fonts_mono
+ @${INSTALL_DATA} ${WRKSRC}/*.pcf ${PREFIX}/lib/X11/fonts/ae_fonts_mono
+ @${INSTALL_DATA} ${WRKSRC}/fonts.dir ${PREFIX}/lib/X11/fonts/ae_fonts_mono
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} "s|X11BASE|${X11BASE}|g" \
+ | ${SED} "s|PORTNAME|${PORTNAME}|g"
+
+.include <bsd.port.post.mk>