aboutsummaryrefslogtreecommitdiff
path: root/archivers/ark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/ark/Makefile')
-rw-r--r--archivers/ark/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index 3280f8f0d4aa..7cff99eabaf0 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -5,19 +5,20 @@ CATEGORIES= archivers kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Archiving tool for KDE
+WWW= https://utils.kde.org/projects/ark/
LICENSE= GPLv2+
USES= cmake compiler:c++11-lang desktop-file-utils gettext libarchive kde:5 \
- cpe qt:5 tar:xz
+ cpe qt:5 tar:xz xorg
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools i18n iconthemes \
itemmodels itemviews jobwidgets khtml kio parts pty service \
solid sonnet textwidgets widgetsaddons windowsystem xmlgui \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus gui network widgets xml \
- buildtools_build qmake_build
-
+ buildtools:build qmake:build
+USE_XORG= x11
USE_LDCONFIG= yes
PATCH_STRIP= -p1