aboutsummaryrefslogtreecommitdiff
path: root/archivers/dpkg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/dpkg/Makefile')
-rw-r--r--archivers/dpkg/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 620a3c2c4c0a..740daed15fe0 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -1,13 +1,13 @@
-# Created by: Hye-Shik Chang <perky@FreeBSD.org>
-
PORTNAME= dpkg
-PORTVERSION= 1.19.7
+PORTVERSION= 1.19.8
+PORTREVISION= 1
CATEGORIES= archivers sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= dpkg_${PORTVERSION}
MAINTAINER= ndowens04@gmail.com
COMMENT= Debian package maintenance system
+WWW= https://packages.debian.org/dpkg
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -20,13 +20,14 @@ RUN_DEPENDS= gtar:archivers/gtar \
USES= compiler:c11 cpe gmake iconv libtool ncurses perl5 pkgconfig \
tar:xz
-
CPE_VENDOR= debian
+USE_CXXSTD= c++14
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
DPKGDIR?= /var/db/dpkg
PLIST_SUB= DPKGDIR=${DPKGDIR}
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --with-admindir=${DPKGDIR} \
--libdir=${PREFIX}/libexec \
--with-libintl-prefix=${LOCALBASE} \