aboutsummaryrefslogtreecommitdiff
path: root/archivers/lazperf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/lazperf/Makefile')
-rw-r--r--archivers/lazperf/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/archivers/lazperf/Makefile b/archivers/lazperf/Makefile
new file mode 100644
index 000000000000..6b095b21e1f5
--- /dev/null
+++ b/archivers/lazperf/Makefile
@@ -0,0 +1,23 @@
+# Created by: lbartoletti <lbartoletti@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= lazperf
+PORTVERSION= 1.1.0
+CATEGORIES= archivers databases geography
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Alternative LAZ implementation for C++ and JavaScript
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake
+CMAKE_ARGS+= -DWITH_TESTS:BOOL=FALSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= hobu
+GH_PROJECT= laz-perf
+
+post-build:
+ ${RM} ${WRKSRC}/laz-perf/portable_endian.hpp.orig
+.include <bsd.port.mk>