aboutsummaryrefslogtreecommitdiff
path: root/archivers/lxqt-archiver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/lxqt-archiver/Makefile')
-rw-r--r--archivers/lxqt-archiver/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/archivers/lxqt-archiver/Makefile b/archivers/lxqt-archiver/Makefile
index b2de5a5fe3a5..423836ef9c12 100644
--- a/archivers/lxqt-archiver/Makefile
+++ b/archivers/lxqt-archiver/Makefile
@@ -1,23 +1,26 @@
PORTNAME= lxqt-archiver
-PORTVERSION= 0.5.0
+PORTVERSION= 0.9.0
CATEGORIES= archivers
MASTER_SITES= LXQT
MAINTAINER= jsm@FreeBSD.org
COMMENT= Qt file archiver
+WWW= https://github.com/lxqt/lxqt-archiver
LICENSE= GPLv2
LIB_DEPENDS= libfm-qt.so:x11/libfm-qt \
- libjson-glib-1.0.so:devel/json-glib \
- libmenu-cache.so:x11/menu-cache \
- libexif.so:graphics/libexif
-RUN_DEPENDS= ${LOCALBASE}/bin/unzip:archivers/unzip
-USES= cmake compiler:c++14-lang desktop-file-utils lxqt pkgconfig tar:xz gnome qt:5 xorg
+ libjson-glib-1.0.so:devel/json-glib \
+ libmenu-cache.so:x11/menu-cache \
+ libexif.so:graphics/libexif
+RUN_DEPENDS= gtar:archivers/gtar \
+ unzip:archivers/unzip
+
+USES= cmake compiler:c++14-lang desktop-file-utils lxqt perl5 pkgconfig \
+ tar:xz gnome qt:5 xorg
USE_GNOME= glib20
-USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
- network printsupport svg widgets x11extras
+USE_QT= buildtools:build qmake:build core gui
USE_LXQT= buildtools lxqt
USE_XORG= xcb