aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-bitshuffle/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/py-bitshuffle/files/patch-setup.py')
-rw-r--r--archivers/py-bitshuffle/files/patch-setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/archivers/py-bitshuffle/files/patch-setup.py b/archivers/py-bitshuffle/files/patch-setup.py
new file mode 100644
index 000000000000..f96dcdf556d3
--- /dev/null
+++ b/archivers/py-bitshuffle/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2022-11-26 00:17:16 UTC
++++ setup.py
+@@ -371,7 +371,7 @@ class build_ext(build_ext_):
+ else:
+ openmpflag = "-fopenmp"
+ archi = platform.machine()
+- if archi in ("i386", "x86_64"):
++ if archi in ("amd64", "i386", "x86_64"):
+ compileflags = COMPILE_FLAGS + ["-march=%s" % self.march]
+ else:
+ compileflags = COMPILE_FLAGS + ["-mcpu=%s" % self.march]