aboutsummaryrefslogtreecommitdiff
path: root/archivers/streamvbyte/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/streamvbyte/Makefile')
-rw-r--r--archivers/streamvbyte/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/archivers/streamvbyte/Makefile b/archivers/streamvbyte/Makefile
index 69708e93a9a7..57cf78c69ef0 100644
--- a/archivers/streamvbyte/Makefile
+++ b/archivers/streamvbyte/Makefile
@@ -1,36 +1,28 @@
PORTNAME= streamvbyte
DISTVERSIONPREFIX= v
-DISTVERSION= 0.4.1
+DISTVERSION= 1.0.0
CATEGORIES= archivers
MAINTAINER= jwb@FreeBSD.org
COMMENT= Integer compression with SIMD based on Google's varint
+WWW= https://github.com/lemire/streamvbyte
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc= Test fails on big-endian systems
-BROKEN_powerpc64= Test fails on big-endian systems
+# From 0.5.2. Retest with 1.0.0.
+BROKEN_powerpc= test fails on big-endian systems
+BROKEN_powerpc64= test fails on big-endian systems
USES= cmake
USE_GITHUB= yes
-USE_LDCONFIG= yes
GH_ACCOUNT= lemire
CFLAGS+= -fPIC # For vbz-compression using static lib
-PLIST_FILES= include/streamvbyte.h \
- include/streamvbyte_zigzag.h \
- include/streamvbytedelta.h \
- lib/libstreamvbyte.so \
- lib/libstreamvbyte.so.0.0.1 \
- lib/libstreamvbyte_static.a
-
-# so version taken from basic Makefile
-post-stage:
- ${RLN} ${STAGEDIR}${PREFIX}/lib/libstreamvbyte.so \
- ${STAGEDIR}${PREFIX}/lib/libstreamvbyte.so.0.0.1
+PLIST_FILES= include/streamvbyte.h include/streamvbyte_zigzag.h \
+ include/streamvbytedelta.h lib/libstreamvbyte.a
do-test:
cd ${WRKDIR}/.build && ./unit