aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/astrometry/Makefile')
-rw-r--r--astro/astrometry/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 2cf63ca17005..26a3d7a07341 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -1,11 +1,13 @@
PORTNAME= astrometry
-PORTVERSION= 0.91
+PORTVERSION= 0.94
+PORTREVISION= 1
CATEGORIES= astro
-MASTER_SITES= http://astrometry.net/downloads/
+MASTER_SITES= https://github.com/dstndstn/${PORTNAME}.net/releases/download/${DISTVERSION}/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
MAINTAINER= rhurlin@FreeBSD.org
COMMENT= Astronomic calibration service
+WWW= https://astrometry.net/
LICENSE= GPLv3+
@@ -16,8 +18,8 @@ BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:graphics/cairo \
libcfitsio.so:astro/cfitsio \
libgsl.so:math/gsl \
- libpng.so:graphics/png \
libnetpbm.so:graphics/netpbm \
+ libpng16.so:graphics/png \
libwcs.so:astro/wcslib
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>0:astro/py-astropy@${PY_FLAVOR} \
${PYNUMPY}
@@ -34,7 +36,7 @@ MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX} \
DATA_INSTALL_DIR=${STAGEDIR}${DATADIR} \
DOC_INSTALL_DIR=${STAGEDIR}${DOCSDIR} \
EXAMPLE_INSTALL_DIR=${STAGEDIR}${EXAMPLESDIR} \
- MAN1_INSTALL_DIR=${STAGEDIR}${PREFIX}/man/man1 \
+ MAN1_INSTALL_DIR=${STAGEDIR}${PREFIX}/share/man/man1 \
PY_BASE_INSTALL_DIR=${STAGEDIR}${PYTHON_LIBDIR}/astrometry \
PYTHON=${PYTHON_CMD} PYTHON_SCRIPT=${PYTHON_CMD}
MAKE_JOBS_UNSAFE= yes
@@ -43,13 +45,12 @@ LDFLAGS+= -lz
CONFLICTS_INSTALL= afni p5-Text-RecordParser # bin/imstat bin/tabmerge
-MANDIRS= ${MANPREFIX}/man/man1
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_DEFAULT= EXAMPLES
-FILES= an-fitstopnm an-pnmtofits astrometry-engine \
+FILES= an-fitstopnm an-pnmtofits astrometry-engine augment-xylist \
build-astrometry-index downsample-fits fit-wcs \
fits-column-merge fits-flip-endian fits-guess-scale \
fitscopy fitsgetext fitsverify get-healpix get-wcs \