aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/gpsdrive/Makefile')
-rw-r--r--astro/gpsdrive/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 14d566417c14..c240646edfe7 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -6,27 +6,34 @@
#
PORTNAME= gpsdrive
-PORTVERSION= 1.20.r1
+PORTVERSION= 1.23.r9
CATEGORIES= astro
-MASTER_SITES= http://www.kraftvoll.at/software/ \
- http://ganter.quant-x.at/software/
+MASTER_SITES= http://gpsdrive.kraftvoll.at/ \
+ http://gpsdrive.teachlinux.com/ \
+ http://gpsdrive.flugfunk.de/ \
+ http://gpsdrive.alumnosfdi.org/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/pre/}
MAINTAINER= molter@gufi.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+BUILD_DEPENDS= ${X11BASE}/bin/gdk-pixbuf-config:${PORTSDIR}/graphics/gdk-pixbuf
+USE_PERL5= yes
USE_GLIB= yes
USE_GMAKE= yes
USE_GTK= yes
USE_LIBTOOL= yes
-
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-debug \
+ --disable-garmin
INSTALLS_SHLIB= yes
MAN1= gpsdrive.1
MANLANG= "" de es
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+
.include <bsd.port.mk>