aboutsummaryrefslogtreecommitdiff
path: root/astro/kosmorro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/kosmorro/Makefile')
-rw-r--r--astro/kosmorro/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/astro/kosmorro/Makefile b/astro/kosmorro/Makefile
index 493ae8cead56..7f55acba7bd6 100644
--- a/astro/kosmorro/Makefile
+++ b/astro/kosmorro/Makefile
@@ -1,32 +1,37 @@
PORTNAME= kosmorro
-PORTVERSION= 0.10.10
+PORTVERSION= 0.10.13
+PORTREVISION= 1
CATEGORIES= astro python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
MAINTAINER= thierry@FreeBSD.org
COMMENT= Ephemerides computation
+WWW= https://kosmorro.space/
LICENSE= AGPLv3
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR}\
- ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR}\
+ ${PYTHON_PKGNAMEPREFIX}python-dateutil>0:devel/py-python-dateutil@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}termcolor>0:devel/py-termcolor@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}kosmorrolib>0:astro/py-kosmorrolib@${PY_FLAVOR}\
+ ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}importlib-metadata>0:devel/py-importlib-metadata@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>0:devel/py-babel@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR}\
- ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR}\
+ ${PYTHON_PKGNAMEPREFIX}python-dateutil>0:devel/py-python-dateutil@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}termcolor>0:devel/py-termcolor@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}kosmorrolib>0:astro/py-kosmorrolib@${PY_FLAVOR}
#USE_GITHUB= yes
-USES= gettext-runtime:run python:3.7+ shebangfix
-USE_PYTHON= distutils noflavors
+USES= gettext-runtime:run python shebangfix
+USE_PYTHON= noflavors pep517
SHEBANG_FILES= ${PORTNAME}
+PLIST_SUB= VE=${PORTVERSION}
+
OPTIONS_DEFINE= PDF
OPTIONS_DEFAULT=PDF
PDF_DESC= Exporting to PDF