aboutsummaryrefslogtreecommitdiff
path: root/astro/kstars/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/kstars/Makefile')
-rw-r--r--astro/kstars/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 2e5de945634d..4f0e1448753c 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -1,35 +1,46 @@
PORTNAME= kstars
-DISTVERSION= 3.5.7
+DISTVERSION= 3.6.6
+PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= astro kde
MASTER_SITES= KDE/stable/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE desktop planetarium
+WWW= https://edu.kde.org/kstars
LICENSE= GPLv2
-LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
- libindidriver.so:devel/indi \
- libqt5keychain.so:security/qtkeychain \
+LIB_DEPENDS= libXISF.so:graphics/libxisf \
+ libcfitsio.so:astro/cfitsio \
+ libqt5keychain.so:security/qtkeychain@qt5 \
libraw.so:graphics/libraw \
+ libgsl.so:math/gsl \
libsecret-1.so:security/libsecret \
+ libnova.so:astro/libnova \
libstellarsolver.so:astro/stellarsolver \
libwcs.so:astro/wcslib
BUILD_DEPENDS= xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
USES= cmake compiler:c++11-lib desktop-file-utils eigen:3 \
- gettext gnome kde:5 localbase:ldflags pkgconfig qt:5 tar:xz
+ gettext gnome kde:5 localbase:ldflags pkgconfig qt:5 tar:xz xorg
USE_GNOME= glib20
USE_KDE= attica auth bookmarks codecs completion config configwidgets\
coreaddons crash dbusaddons guiaddons i18n \
iconthemes init itemviews jobwidgets kio newstuff notifications \
notifyconfig parts plotting service solid texteditor \
- widgetsaddons xmlgui \
- doctools_build ecm_build
+ widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build
USE_QT= concurrent core datavis3d dbus declarative gui multimedia \
network opengl printsupport sql svg testlib websockets widgets \
xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
+USE_XORG= x11
+
+# Requires devel/indi >= 2.0.0 which is not in the ports tree yet. KStars builds
+# fine with INDI 2.0.3, but support for the INDI 2.0 API in astro/phd2 and
+# astro/stellarium as of 2023-08-10 appear to be works in progress.
+CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_INDI
.include <bsd.port.mk>