aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/libosmium/Makefile')
-rw-r--r--astro/libosmium/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index a58067ea8baf..4f42d9420bcd 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -26,6 +26,12 @@ GH_ACCOUNT= osmcode
USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
+# if/when corresponding ports appear in the tree, these will need to
+# be turned from depends
+CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
+ -DINSTALL_PROTOZERO:BOOL=ON \
+ -DINSTALL_UTFCPP:BOOL=ON
+
# though it builds tests, the library itself is header-only
NO_ARCH= yes