aboutsummaryrefslogtreecommitdiff
path: root/astro/mepo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/mepo/Makefile')
-rw-r--r--astro/mepo/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/astro/mepo/Makefile b/astro/mepo/Makefile
new file mode 100644
index 000000000000..da0f836e5f15
--- /dev/null
+++ b/astro/mepo/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= mepo
+DISTVERSION= 1.0_rc1
+CATEGORIES= astro geography wayland
+MASTER_SITES= https://git.sr.ht/~mil/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Fast, simple, and hackable OSM map viewer
+WWW= https://sr.ht/~mil/Mepo/
+
+LICENSE= GPLv3+ OFL11
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= zig>=0.9.0:lang/zig
+LIB_DEPENDS= libcurl.so:ftp/curl
+RUN_DEPENDS= jq:textproc/jq
+
+USES= pkgconfig sdl shebangfix
+USE_SDL= gfx2 image2 ttf2
+SHEBANG_FILES= scripts/*
+SHEBANG_LANG= sh
+sh_CMD= /bin/sh
+MAKE_ENV= DESTDIR="${STAGEDIR}"
+CONFIGURE_ARGS= --prefix "${PREFIX}" \
+ ${WITH_DEBUG:D:U-Drelease-fast} \
+ -Dcpu=${CPUTYPE:Ubaseline} \
+ --verbose
+NO_INSTALL= yes # strip(1) breaks runtime
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},' \
+ ${WRKSRC}/scripts/mepo_ui_menu_user_pin_updater.sh
+ @${REINPLACE_CMD} -e 's/pidof/pgrep/' \
+ -e 's/busctl/basuctl/' \
+ ${WRKSRC}/scripts/mepo_ui_helper_menu.sh
+
+do-build:
+ @(cd ${WRKSRC} && ${MAKE_ENV} zig build ${CONFIGURE_ARGS})
+
+do-test:
+ @(cd ${WRKSRC} && ${TEST_ENV} zig build test ${CONFIGURE_ARGS})
+
+.include <bsd.port.mk>