aboutsummaryrefslogtreecommitdiff
path: root/astro/oskar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/oskar/Makefile')
-rw-r--r--astro/oskar/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/astro/oskar/Makefile b/astro/oskar/Makefile
index 3ee914634f9b..2dd172789014 100644
--- a/astro/oskar/Makefile
+++ b/astro/oskar/Makefile
@@ -18,8 +18,12 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libhdf5.so:science/hdf5 \
libsz.so:science/libaec
-USES= cmake compiler:c++11-lang localbase:ldflags python qt:5 \
- shebangfix
+USES= cmake localbase:ldflags python qt:5 shebangfix
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
USE_QT= core gui network widgets buildtools:build qmake:build
USE_LDCONFIG= yes