aboutsummaryrefslogtreecommitdiff
path: root/astro/py-aipy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/py-aipy/Makefile')
-rw-r--r--astro/py-aipy/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
new file mode 100644
index 000000000000..9a1bb2fb23c1
--- /dev/null
+++ b/astro/py-aipy/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-aipy
+# Date created: 2008-11-11
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aipy
+PORTVERSION= 0.8.3
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Astronomical Interferometry in PYthon
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_SITELIBDIR}/ephem/__init__.py:${PORTSDIR}/astro/pyephem \
+ ${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>