aboutsummaryrefslogtreecommitdiff
path: root/astro/weather/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/weather/Makefile')
-rw-r--r--astro/weather/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index bc86b77b57d6..06b7366f2c54 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -13,6 +13,7 @@ COMMENT= Utility to provide current weather conditions and forecasts
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_ARCH= yes
USES= python shebangfix tar:xz
PLIST_FILES= bin/${PORTNAME} \
@@ -35,12 +36,6 @@ PYCACHE_DIR= __pycache__/
PYCACHE_FILE= ${PORTNAME}.cpython-${PYTHON_SUFFIX}
.endif
-.if ${PYTHON_REL} < 3500
-PYTHON_PYOEXTENSION= pyo
-.else
-PYTHON_PYOEXTENSION= opt-1.pyc
-.endif
-
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
@${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py