aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/kstars/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 498c3e243410..293cada92556 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kstars
DISTVERSION= 3.6.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= astro kde
MASTER_SITES= KDE/stable/${PORTNAME}
@@ -14,24 +14,27 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libindidriver.so:devel/indi \
libqt5keychain.so:security/qtkeychain@qt5 \
libraw.so:graphics/libraw \
+ libgsl.so:math/gsl \
libsecret-1.so:security/libsecret \
+ libnova-0.15.so:astro/libnova \
libstellarsolver.so:astro/stellarsolver \
libwcs.so:astro/wcslib
BUILD_DEPENDS= xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
USES= cmake compiler:c++11-lib desktop-file-utils eigen:3 \
- gettext gnome kde:5 localbase:ldflags pkgconfig qt:5 tar:xz
+ gettext gnome kde:5 localbase:ldflags pkgconfig qt:5 tar:xz xorg
USE_GNOME= glib20
USE_KDE= attica auth bookmarks codecs completion config configwidgets\
coreaddons crash dbusaddons guiaddons i18n \
iconthemes init itemviews jobwidgets kio newstuff notifications \
notifyconfig parts plotting service solid texteditor \
- widgetsaddons xmlgui \
+ widgetsaddons windowsystem xmlgui \
doctools_build ecm_build
USE_QT= concurrent core datavis3d dbus declarative gui multimedia \
network opengl printsupport sql svg testlib websockets widgets \
xml \
buildtools_build qmake_build
+USE_XORG= x11
.include <bsd.port.mk>