aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-kde4/files
diff options
context:
space:
mode:
Diffstat (limited to 'audio/amarok-kde4/files')
-rw-r--r--audio/amarok-kde4/files/extra-amarok_src_expression.h16
-rw-r--r--audio/amarok-kde4/files/patch-amarok-src-statusbar-selectLabel.h11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp16
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_playlist.cpp13
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_xmlloader.h13
-rw-r--r--audio/amarok-kde4/files/patch-configure31
13 files changed, 0 insertions, 198 deletions
diff --git a/audio/amarok-kde4/files/extra-amarok_src_expression.h b/audio/amarok-kde4/files/extra-amarok_src_expression.h
deleted file mode 100644
index 47b874c41315..000000000000
--- a/audio/amarok-kde4/files/extra-amarok_src_expression.h
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/expression.h.orig
-+++ amarok/src/expression.h
-@@ -27,8 +27,8 @@
- {
- QString field;
- QString text;
-- bool negate: 1;
-- enum { Contains, Less, More } match: 2;
-+ bool negate;
-+ enum { Contains, Less, More } match;
- expression_element(): negate( false ), match( Contains ) { }
- };
- typedef QValueVector<expression_element> or_list;
diff --git a/audio/amarok-kde4/files/patch-amarok-src-statusbar-selectLabel.h b/audio/amarok-kde4/files/patch-amarok-src-statusbar-selectLabel.h
deleted file mode 100644
index 74ffa63db11e..000000000000
--- a/audio/amarok-kde4/files/patch-amarok-src-statusbar-selectLabel.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/statusbar/selectLabel.h.orig Sat Jul 1 20:30:36 2006
-+++ amarok/src/statusbar/selectLabel.h Sat Jul 1 20:31:51 2006
-@@ -126,7 +126,7 @@
- if( !isEnabled() )
- tip += i18n("&nbsp;<br>&nbsp;<i>Disabled</i>");
- else if( AmarokConfig::favorTracks() &&
-- m_action == amaroK::actionCollection()->action( "random_mode" ) ) //hack?
-+ m_action == static_cast<amaroK::SelectAction*>( amaroK::actionCollection()->action( "random_mode" ) ) ) //hack?
- {
- KSelectAction *a = static_cast<KSelectAction*>( amaroK::actionCollection()->action( "favor_tracks" ) );
- tip += QString("<br><br>") + i18n("%1: %2")
diff --git a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp b/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
deleted file mode 100644
index 14473120eaa0..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/lastfm.cpp.orig
-+++ amarok/src/lastfm.cpp
-@@ -729,7 +729,7 @@
-
- QCString md5pass = KMD5( KMD5( m_password.utf8() ).hexDigest() + currentTime ).hexDigest();
-
-- QString token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
-+ token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
- .arg( QString( QUrl( currentUsername() ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( md5pass ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( challenge ).encodedPathAndQuery() ) )
diff --git a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
deleted file mode 100644
index 63bc30ea1ca7..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/mediadevice/generic/genericmediadevice.cpp.orig
-+++ amarok/src/mediadevice/generic/genericmediadevice.cpp
-@@ -406,7 +406,7 @@
- debug() << "Renaming: " << src << " to: " << dst << endl;
-
- //do we want a progress dialog? If so, set last false to true
-- if( KIO::NetAccess::file_move( KURL::fromPathOrURL(src), KURL::fromPathOrURL(dst), -1, false, false, false ) )
-+ if( KIO::NetAccess::file_move( KURL::fromPathOrURL(src), KURL::fromPathOrURL(dst), -1, false, false, 0 ) )
- {
- m_mfm.erase( m_mim[item]->getFullName() );
- m_mim[item]->setNamesFromBase( item->text(0) );
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
deleted file mode 100644
index 0a969a69e2a3..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/Makefile.in.orig
-+++ amarok/src/metadata/audible/Makefile.in
-@@ -435,7 +435,7 @@
- xmms_cflags = @xmms_cflags@
- xmms_libs = @xmms_libs@
- SUBDIRS =
--INCLUDES = $(all_includes) $(taglib_includes)
-+INCLUDES = -I$(top_srcdir)/amarok/src $(all_includes) $(taglib_includes)
- #>- METASOURCES = AUTO
- libtagaudible_la_LDFLAGS = $(all_libraries)
- noinst_LTLIBRARIES = libtagaudible.la
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
deleted file mode 100644
index 253f54878017..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibleproperties.h.orig
-+++ amarok/src/metadata/audible/audibleproperties.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/audioproperties.h>
- #include <taglib/tstring.h>
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
deleted file mode 100644
index 65941ffd4602..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibletag.h.orig
-+++ amarok/src/metadata/audible/audibletag.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/tag.h>
- #include "taglib_audiblefile.h"
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
deleted file mode 100644
index 35000f132539..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4file.cpp.orig
-+++ amarok/src/metadata/mp4/mp4file.cpp
-@@ -23,9 +23,8 @@
-
- #include "mp4tag.h"
- #include <tfile.h>
--#include <audioproperties.h>
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- #define MP4V2_HAS_WRITE_BUG 1
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
deleted file mode 100644
index 7f39cdfb69c2..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4properties.cpp.orig
-+++ amarok/src/metadata/mp4/mp4properties.cpp
-@@ -29,7 +29,7 @@
- #include <systems.h>
- #endif
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
deleted file mode 100644
index 0121a707e195..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4tag.cpp.orig
-+++ amarok/src/metadata/mp4/mp4tag.cpp
-@@ -23,7 +23,7 @@
- #include "mp4tag.h"
-
- #include <tag.h>
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_playlist.cpp b/audio/amarok-kde4/files/patch-amarok_src_playlist.cpp
deleted file mode 100644
index eb1139a37507..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_playlist.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/playlist.cpp.orig
-+++ amarok/src/playlist.cpp
-@@ -3168,6 +3168,7 @@
- stream << "</playlist>\n";
-
- QTextStream fstream( &file );
-+ fstream.setEncoding( QTextStream::UnicodeUTF8 );
- fstream << buffer;
- }
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h b/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
deleted file mode 100644
index 51200453662c..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/xmlloader.h.orig
-+++ amarok/src/xmlloader.h
-@@ -173,6 +173,7 @@
-
- public: //fucking moc, these should be private
- class ThreadedLoader;
-+ friend class ThreadedLoader;
- class SimpleLoader;
- };
-
diff --git a/audio/amarok-kde4/files/patch-configure b/audio/amarok-kde4/files/patch-configure
deleted file mode 100644
index 12fa6d8f74eb..000000000000
--- a/audio/amarok-kde4/files/patch-configure
+++ /dev/null
@@ -1,31 +0,0 @@
---- configure.orig Wed Aug 17 17:29:59 2005
-+++ configure Wed Aug 17 17:31:59 2005
-@@ -35889,7 +35889,7 @@
- if test "$with_libvisual" = "yes"; then
- ## libvisual plugin depends on sdl
- # Extract the first word of "sdl-config", so it can be a program name with args.
--set dummy sdl-config; ac_word=$2
-+set dummy $SDL_CONFIG; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_prog_SDL_CONFIG+set}" = set; then
-@@ -35924,15 +35924,15 @@
- fi
-
-
-- if test x$SDL_CONFIG = xyes; then
-- sdl_cflags=`sdl-config --cflags`
-- sdl_libs=`sdl-config --libs`
-+ if test -n $SDL_CONFIG ; then
-+ sdl_cflags=`$SDL_CONFIG --cflags`
-+ sdl_libs=`$SDL_CONFIG --libs`
- fi
-
-
-
-
-- if test x$PKGCONFIGFOUND = xyes -a x$SDL_CONFIG = xyes; then
-+ if test x$PKGCONFIGFOUND = xyes -a -n $SDL_CONFIG ; then
-
-
- succeeded=no