aboutsummaryrefslogtreecommitdiff
path: root/audio/ampache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ampache/Makefile')
-rw-r--r--audio/ampache/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/audio/ampache/Makefile b/audio/ampache/Makefile
index c001eb72e035..d28ad7a0f2f5 100644
--- a/audio/ampache/Makefile
+++ b/audio/ampache/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ampache
-PORTVERSION= 5.0.0
+PORTVERSION= 5.6.0
+PORTREVISION= 1
DISTVERSIONSUFFIX= _all
CATEGORIES= audio www
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
@@ -7,11 +8,12 @@ PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= crees@FreeBSD.org
COMMENT= Web-based Audio file manager
+WWW= https://ampache.org/
LICENSE= AGPLv3+
USES= cpe zip gettext php:flavors mysql
-USE_PHP= pdo pdo_mysql hash session json intl simplexml curl dom xml
+USE_PHP= pdo pdo_mysql session intl simplexml curl dom xml
CONFLICTS_INSTALL= ampache-php* # etc/periodic/daily/500.ampache-cron man/man1/ampache.1.gz
@@ -37,9 +39,12 @@ do-build:
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
+ for f in $$(${FIND} ${WRKSRC} -name .htaccess); do \
+ ${MV} $$f $$f.dist; \
+ done
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} '-not -regex ^./man.*')
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} '-not -regex ^./docs.* -a -not -name *.bak')
- ${INSTALL_MAN} ${WRKSRC}/docs/man/man1/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/man1/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/share/man/man1/
${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${WRKDIR}/500.ampache-cron ${STAGEDIR}${PREFIX}/etc/periodic/daily/