aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/audacity/Makefile')
-rw-r--r--audio/audacity/Makefile161
1 files changed, 88 insertions, 73 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index c85b5cf08deb..2066cd6f58b3 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -1,54 +1,85 @@
-# Created by: Marc van Woerkom <3d@FreeBSD.org>
-
PORTNAME= audacity
-DISTVERSIONPREFIX= minsrc-
-DISTVERSION= 3.0.2
-PORTREVISION= 1
+DISTVERSIONPREFIX= Audacity-
+DISTVERSION= 3.5.1
CATEGORIES= audio
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/Audacity-${PORTVERSION}/
MAINTAINER= xxjack12xx@gmail.com
COMMENT= GUI editor for digital audio waveforms
+WWW= https://www.audacityteam.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libasound.so:audio/alsa-lib \
- libexpat.so:textproc/expat2 \
+BUILD_DEPENDS= conan:sysutils/conan \
+ rapidjson>0:devel/rapidjson
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libharfbuzz.so:print/harfbuzz \
+ liblilv-0.so:audio/lilv \
+ libmp3lame.so:audio/lame \
+ libmpg123.so:audio/mpg123 \
+ libopus.so:audio/opus \
+ libopusfile.so:audio/opusfile \
libportaudio.so:audio/portaudio \
+ libportmidi.so:audio/portmidi \
+ libserd-0.so:devel/serd \
libsndfile.so:audio/libsndfile \
+ libsord-0.so:devel/sord \
libsoxr.so:audio/libsoxr \
- libsqlite3.so:databases/sqlite3
-
-USES= cmake compiler:c++14-lang cpe desktop-file-utils gettext \
- gnome libtool python:build pkgconfig shared-mime-info tar:xz
-USE_GNOME= cairo gtk30
-USE_WX= 3.1+
+ libsratom-0.so:audio/sratom \
+ libsqlite3.so:databases/sqlite3 \
+ libsuil-0.so:audio/suil \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libwavpack.so:audio/wavpack
+
+USES= cmake compiler:c++20-lang cpe desktop-file-utils gettext \
+ gnome libtool python:build pkgconfig shared-mime-info
+CPE_VENDOR= audacityteam
+
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
+USE_WX= 3.2+
WX_COMPS= wx
-INSTALLS_ICONS= yes
-PORTDOCS= README.txt
-CMAKE_ARGS= -Daudacity_lib_preference:STRING=system \
+CMAKE_ARGS= -DAUDACITY_BUILD_LEVEL=2 \
+ -Daudacity_lib_preference:STRING=system \
+ -Daudacity_use_curl:STRING=system \
-Daudacity_use_expat:STRING=system \
- -Daudacity_use_wxwidgets:STRING=system \
- -Daudacity_use_soxr:STRING=system \
- -Daudacity_use_sndfile:STRING=system \
- -Daudacity_use_portsmf:STRING=local \
+ -Daudacity_use_jpeg:STRING=system \
+ -Daudacity_use_libmp3lame:STRING=system \
+ -Daudacity_use_libmpg123:STRING=system \
+ -Daudacity_use_libopus:STRING=system \
+ -Daudacity_use_libsndfile:STRING=system \
+ -Daudacity_use_lv2:STRING=system \
+ -Daudacity_use_midi:STRING=system \
+ -Daudacity_use_nyquist:STRING=local \
+ -Daudacity_use_portaudio:STRING=system \
-Daudacity_use_portmixer:STRING=local \
- -Daudacity_use_portaudio:STRING=system
-CMAKE_OFF= audacity_use_pch
+ -Daudacity_use_portsmf:STRING=local \
+ -Daudacity_use_png:STRING=system \
+ -Daudacity_use_rapidjson:STRING=system \
+ -Daudacity_use_soxr:STRING=system \
+ -Daudacity_use_sqlite:STRING=system \
+ -Daudacity_use_wavpack=system \
+ -Daudacity_use_wxwidgets:STRING=system \
+ -Daudacity_use_zlib:STRING=system
+
+CMAKE_ON= audacity_bundle_gplv3 audacity_conan_allow_prebuilt_binaries audacity_obey_system_dependencies
+CMAKE_OFF= audacity_has_audiocom_upload audacity_conan_enabled audacity_conan_force_build_dependencies \
+ audacity_has_crashreports audacity_has_networking audacity_has_updates_check audacity_has_url_schemes_support \
+ audacity_has_tests audacity_has_vst3 audacity_perform_codesign audacity_use_pch
+
+# TODO: fix NLS support properly
+PLIST_SUB+= NLS=""
+PORTDOCS= README.md
-OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
- MIDI OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
- VORBIS VST
-OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LV2 MAD MIDI OGG SBSMS \
+OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA MANUAL \
+ OGG SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
+OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LADSPA OGG SBSMS \
SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_EXCLUDE_i386= SBSMS
+OPTIONS_SUB= yes
-LAME_DESC= Use lame for import and export support
-LV2_DESC= Add LV2 plug-in support
-MAD_DESC= Use libmad for mp2/3 decoding support
-MIDI_DESC= MIDI support
+MANUAL_DESC= Include manual
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
TWOLAME_DESC= Use libtwolame for MP2 export support
@@ -60,70 +91,47 @@ DEBUG_CMAKE_ON= wxWidgets_USE_DEBUG
DOCS_BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man \
docbook2man:textproc/docbook-utils
+FFMPEG_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libavcodec.pc:multimedia/ffmpeg
+FFMPEG_RUN_DEPENDS= ${LOCALBASE}/lib/libavformat.so:multimedia/ffmpeg
FFMPEG_CMAKE_ON= -Daudacity_use_ffmpeg:STRING=loaded
FFMPEG_CMAKE_OFF= -Daudacity_use_ffmpeg:STRING=off
-FFMPEG_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libavcodec.pc:multimedia/ffmpeg
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FLAC_CMAKE_ON= -Daudacity_use_flac:STRING=system
-FLAC_CMAKE_OFF= -Daudacity_use_flac:STRING=local
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
+FLAC_CMAKE_ON= -Daudacity_use_libflac:STRING=system
+FLAC_CMAKE_OFF= -Daudacity_use_libflac:STRING=off
-ID3TAG_CMAKE_ON= -Daudacity_use_id3tag:STRING=system
-ID3TAG_CMAKE_OFF= -Daudacity_use_id3tag:STRING=off
ID3TAG_LIB_DEPENDS= libid3tag.so:audio/libid3tag
+ID3TAG_CMAKE_ON= -Daudacity_use_libid3tag:STRING=system
+ID3TAG_CMAKE_OFF= -Daudacity_use_libid3tag:STRING=off
-LADSPA_CMAKE_BOOL= audacity_use_ladspa
LADSPA_RUN_DEPENDS= listplugins:audio/ladspa
+LADSPA_CMAKE_BOOL= audacity_use_ladspa
-LAME_CMAKE_ON= -Daudacity_use_lame:STRING=system
-LAME_CMAKE_OFF= -Daudacity_use_lame:STRING=local
-LAME_BUILD_DEPENDS= ${LOCALBASE}/include/lame/lame.h:audio/lame
-LAME_CPPFLAGS= -I${LOCALBASE}/include/lame
-LAME_LDFLAGS= -L${LOCALBASE}/lib
-LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-
-LV2_CMAKE_ON= -Daudacity_use_lv2:STRING=system
-LV2_CMAKE_OFF= -Daudacity_use_lv2:STRING=off
-LV2_LIB_DEPENDS= liblilv-0.so:audio/lilv \
- libserd-0.so:devel/serd \
- libsord-0.so:devel/sord \
- libsratom-0.so:audio/sratom \
- libsuil-0.so:audio/suil
-
-MAD_CMAKE_ON= -Daudacity_use_mad:STRING=system
-MAD_CMAKE_OFF= -Daudacity_use_mad:STRING=off
-MAD_LIB_DEPENDS= libmad.so:audio/libmad
-
-MIDI_CMAKE_ON= -Daudacity_use_midi:STRING=local
-MIDI_CMAKE_OFF= -Daudacity_use_midi:STRING=off
-
-# TODO: fix NLS support properly
-PLIST_SUB+= NLS=""
+MANUAL_CMAKE_BOOL= audacity_package_manual
-OGG_CMAKE_ON= -Daudacity_use_ogg:STRING=system
-OGG_CMAKE_OFF= -Daudacity_use_ogg:STRING=local
OGG_LIB_DEPENDS= libogg.so:audio/libogg
+OGG_CMAKE_ON= -Daudacity_use_libogg:STRING=system
+OGG_CMAKE_OFF= -Daudacity_use_libogg:STRING=off
SBSMS_CMAKE_ON= -Daudacity_use_sbsms:STRING=local
SBSMS_CMAKE_OFF= -Daudacity_use_sbsms:STRING=off
+SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
SOUNDTOUCH_CMAKE_ON= -Daudacity_use_soundtouch:STRING=system
SOUNDTOUCH_CMAKE_OFF= -Daudacity_use_soundtouch:STRING=off
-SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:audio/soundtouch
+TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame
TWOLAME_CMAKE_ON= -Daudacity_use_twolame:STRING=system
TWOLAME_CMAKE_OFF= -Daudacity_use_twolame:STRING=off
-TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame
+VAMP_LIB_DEPENDS= libvamp-hostsdk.so:audio/vamp-plugin-sdk
VAMP_CMAKE_ON= -Daudacity_use_vamp:STRING=system
VAMP_CMAKE_OFF= -Daudacity_use_vamp:STRING=off
-VAMP_LIB_DEPENDS= libvamp-hostsdk.so:audio/vamp-plugin-sdk
-VORBIS_CMAKE_ON= -Daudacity_use_vorbis:STRING=system
-VORBIS_CMAKE_OFF= -Daudacity_use_vorbis:STRING=off
VORBIS_LIB_DEPENDS= libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
+VORBIS_CMAKE_ON= -Daudacity_use_libvorbis:STRING=system
+VORBIS_CMAKE_OFF= -Daudacity_use_libvorbis:STRING=off
VST_CMAKE_BOOL= audacity_use_vst
@@ -135,14 +143,21 @@ CMAKE_ARGS+= -DHAVE_MMX:BOOL=OFF \
-DHAVE_SSE2:BOOL=OFF
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1302508
+# Workarounds for buggy libc++ std::conjunction
+EXTRA_PATCHES= ${PATCHDIR}/extra-libraries_lib-utility_TypeList.cpp \
+ ${PATCHDIR}/extra-libraries_lib-utility_TypeList.h \
+ ${PATCHDIR}/extra-libraries_lib-utility_TypeSwitch.h
+.endif
+
post-install:
- @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} \
- bin/${PORTNAME} \
- share/audacity/modules/mod-script-pipe.so
@${RM} ${STAGEDIR}${DOCSDIR}/LICENSE.txt
- # delete empty directories: https://github.com/audacity/audacity/issues/808
+ #delete empty directories: https://github.com/audacity/audacity/issues/808
@${FIND} ${STAGEDIR} -type d -empty -delete
+post-install-DEBUG-off:
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/audacity -name '*.so*' -exec ${STRIP_CMD} {} +
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}