aboutsummaryrefslogtreecommitdiff
path: root/audio/boca
diff options
context:
space:
mode:
Diffstat (limited to 'audio/boca')
-rw-r--r--audio/boca/Makefile3
-rw-r--r--audio/boca/distinfo6
-rw-r--r--audio/boca/files/patch-components_decoder_Makefile13
-rw-r--r--audio/boca/files/patch-components_encoder_Makefile13
-rw-r--r--audio/boca/pkg-descr2
-rw-r--r--audio/boca/pkg-plist6
6 files changed, 37 insertions, 6 deletions
diff --git a/audio/boca/Makefile b/audio/boca/Makefile
index 9b559c00cbad..3f407f3b1d82 100644
--- a/audio/boca/Makefile
+++ b/audio/boca/Makefile
@@ -1,10 +1,11 @@
PORTNAME= ${GH_PROJECT:tl}
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.7
DISTVERSIONPREFIX= v
CATEGORIES= audio
MAINTAINER= danfe@FreeBSD.org
COMMENT= Audio component collection and framework
+WWW= https://github.com/enzo1982/BoCA
LICENSE= GPLv2+
diff --git a/audio/boca/distinfo b/audio/boca/distinfo
index 0e0a4ff99398..1eeacf7e3f5a 100644
--- a/audio/boca/distinfo
+++ b/audio/boca/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1624795545
-SHA256 (enzo1982-BoCA-v1.0.5_GH0.tar.gz) = 5afb742beff8546c2773735fa2e5c592452b91afe3a4712dd230273cd83d7b94
-SIZE (enzo1982-BoCA-v1.0.5_GH0.tar.gz) = 142153923
+TIMESTAMP = 1678031037
+SHA256 (enzo1982-BoCA-v1.0.7_GH0.tar.gz) = 2c0b99b377e5bc5aeb046e34e25f8bc8af6427af30bf3105dd4318ed228a6a0f
+SIZE (enzo1982-BoCA-v1.0.7_GH0.tar.gz) = 233588750
diff --git a/audio/boca/files/patch-components_decoder_Makefile b/audio/boca/files/patch-components_decoder_Makefile
new file mode 100644
index 000000000000..1b0fa52111c0
--- /dev/null
+++ b/audio/boca/files/patch-components_decoder_Makefile
@@ -0,0 +1,13 @@
+--- components/decoder/Makefile.orig 2023-03-05 15:43:57 UTC
++++ components/decoder/Makefile
+@@ -6,6 +6,10 @@ include $(dir $(firstword $(MAKEFILE_LIST)))/$(BOCA_PA
+
+ FOLDERS = alac cuesheet faad2 fdkaac flac mac mpg123 opus sndfile speex vorbis
+
++ifneq ($(BUILD_OSX),True)
++ FOLDERS += lame mad
++endif
++
+ ifeq ($(BUILD_UNIX),True)
+ ifneq ($(BUILD_HAIKU),True)
+ ifneq ($(BUILD_OPENBSD),True)
diff --git a/audio/boca/files/patch-components_encoder_Makefile b/audio/boca/files/patch-components_encoder_Makefile
new file mode 100644
index 000000000000..dd83a7d4a8a4
--- /dev/null
+++ b/audio/boca/files/patch-components_encoder_Makefile
@@ -0,0 +1,13 @@
+--- components/encoder/Makefile.orig 2023-03-05 15:43:57 UTC
++++ components/encoder/Makefile
+@@ -6,6 +6,10 @@ include $(dir $(firstword $(MAKEFILE_LIST)))/$(BOCA_PA
+
+ FOLDERS = fdkaac flac lame mac meh opus sndfile speex vorbis
+
++ifneq ($(BUILD_OSX),True)
++ FOLDERS += faac voaacenc
++endif
++
+ ifeq ($(USE_WINE),True)
+ FOLDERS += coreaudioconnect
+ endif
diff --git a/audio/boca/pkg-descr b/audio/boca/pkg-descr
index a53ce392d570..47f5eda8c606 100644
--- a/audio/boca/pkg-descr
+++ b/audio/boca/pkg-descr
@@ -2,5 +2,3 @@ BoCA is the component framework behind the fre:ac audio converter.
It provides unified interfaces for audio components like encoders,
decoders, taggers, and extensions as well as the code to support
communication between the application and its components.
-
-WWW: https://github.com/enzo1982/BoCA
diff --git a/audio/boca/pkg-plist b/audio/boca/pkg-plist
index 9b9fcfd5b070..b0feed0161e4 100644
--- a/audio/boca/pkg-plist
+++ b/audio/boca/pkg-plist
@@ -58,6 +58,7 @@ lib/boca/boca.dsp.rnnoise/cb.rnnn
lib/boca/boca.dsp.rnnoise/lq.rnnn
lib/boca/boca.dsp.rnnoise/mp.rnnn
lib/boca/boca.dsp.rnnoise/sh.rnnn
+lib/boca/boca_decoder_alac.1.0.so
lib/boca/boca_decoder_alac.1.0.xml
lib/boca/boca_decoder_als.1.0.xml
lib/boca/boca_decoder_cdio.1.0.so
@@ -74,6 +75,7 @@ lib/boca/boca_decoder_ffmpeg_dsd.1.0.xml
lib/boca/boca_decoder_ffmpeg_dss.1.0.xml
lib/boca/boca_decoder_ffmpeg_dts.1.0.xml
lib/boca/boca_decoder_ffmpeg_flv_audio.1.0.xml
+lib/boca/boca_decoder_ffmpeg_m4a.1.0.xml
lib/boca/boca_decoder_ffmpeg_m4v_audio.1.0.xml
lib/boca/boca_decoder_ffmpeg_mac.1.0.xml
lib/boca/boca_decoder_ffmpeg_mkv_audio.1.0.xml
@@ -84,6 +86,8 @@ lib/boca/boca_decoder_ffmpeg_mpg_audio.1.0.xml
lib/boca/boca_decoder_ffmpeg_purevoice.1.0.xml
lib/boca/boca_decoder_ffmpeg_realaudio.1.0.xml
lib/boca/boca_decoder_ffmpeg_tak.1.0.xml
+lib/boca/boca_decoder_ffmpeg_tta.1.0.xml
+lib/boca/boca_decoder_ffmpeg_vqf.1.0.xml
lib/boca/boca_decoder_ffmpeg_wavpack.1.0.xml
lib/boca/boca_decoder_ffmpeg_webm_audio.1.0.xml
lib/boca/boca_decoder_ffmpeg_wma.1.0.xml
@@ -113,6 +117,8 @@ lib/boca/boca_dsp_hdcd.1.0.so
lib/boca/boca_dsp_resample.1.0.so
lib/boca/boca_dsp_rnnoise.1.0.so
lib/boca/boca_dsp_rubberband.1.0.so
+lib/boca/boca_dsp_surround.1.0.so
+lib/boca/boca_dsp_volume.1.0.so
lib/boca/boca_encoder_aften.1.0.xml
lib/boca/boca_encoder_als.1.0.xml
lib/boca/boca_encoder_atrac1enc.1.0.xml