aboutsummaryrefslogtreecommitdiff
path: root/audio/carla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/carla/Makefile')
-rw-r--r--audio/carla/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/carla/Makefile b/audio/carla/Makefile
index 758a8787a174..290c7c81bb33 100644
--- a/audio/carla/Makefile
+++ b/audio/carla/Makefile
@@ -1,8 +1,11 @@
PORTNAME= Carla
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.3
+DISTVERSION= 2.5.0
CATEGORIES= audio
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 5aba957f3cf0fb4dcef4d2add679603e6c048fb4.diff:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Audio plugin host for Jack and PulseAudio
@@ -14,13 +17,14 @@ LIB_DEPENDS= liblo.so:audio/liblo \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblo>0:audio/py-pyliblo@${PY_FLAVOR}
USES= compiler:c++11-lib desktop-file-utils gl gmake gnome localbase \
- pkgconfig pyqt:5 python:3.4+ qt:5 shared-mime-info shebangfix \
+ pkgconfig pyqt:5 python:3.4+ qt:5 sdl shared-mime-info shebangfix \
tar:bz2 xorg
USE_PYQT= pyqt5 sip
USE_GNOME= gtk20 gtk30
USE_QT= core gui widgets buildtools_build
USE_GL= gl
USE_XORG= x11
+USE_SDL= sdl2
USE_LDCONFIG= ${PREFIX}/lib/carla
CONFLICTS_BUILD= rtaudio rtmidi