aboutsummaryrefslogtreecommitdiff
path: root/audio/deadbeef
diff options
context:
space:
mode:
Diffstat (limited to 'audio/deadbeef')
-rw-r--r--audio/deadbeef/Makefile9
-rw-r--r--audio/deadbeef/files/patch-threading__pthread.c11
-rw-r--r--audio/deadbeef/pkg-descr2
3 files changed, 16 insertions, 6 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 7e908c827c5b..d97e2f92e346 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -1,13 +1,12 @@
-# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
-
PORTNAME= deadbeef
PORTVERSION= 0.7.2
-PORTREVISION= 19
+PORTREVISION= 27
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/
MAINTAINER= danfe@FreeBSD.org
COMMENT= Ultimate music player for Unix-like systems
+WWW= http://deadbeef.sourceforge.net/
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
@@ -25,7 +24,6 @@ CFLAGS+= -Wno-narrowing
LDFLAGS_i386= -Wl,-z,notext
LIBS+= -L${LOCALBASE}/lib -lexecinfo -lintl
USE_GNOME= intltool
-INSTALLS_ICONS= yes
SHEBANG_FILES= yasmwrapper.sh
INSTALL_TARGET= install-strip
@@ -209,6 +207,9 @@ PLIST_SUB+= MP3=""
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's,register ,,' \
+ ${WRKSRC}/plugins/adplug/adplug/rix.cpp \
+ ${WRKSRC}/plugins/adplug/libbinio/binio.cpp
# Do not link to libsupc++ which may be PIC-unsafe (breaks 64-bit arches)
@${REINPLACE_CMD} -e 's, -lsupc++,,' \
${WRKSRC}/plugins/adplug/Makefile.in \
diff --git a/audio/deadbeef/files/patch-threading__pthread.c b/audio/deadbeef/files/patch-threading__pthread.c
new file mode 100644
index 000000000000..af7e3a83cced
--- /dev/null
+++ b/audio/deadbeef/files/patch-threading__pthread.c
@@ -0,0 +1,11 @@
+--- threading_pthread.c.orig 2016-06-19 11:26:18 UTC
++++ threading_pthread.c
+@@ -54,7 +54,7 @@ thread_start (void (*fn)(void *ctx), void *ctx) {
+ fprintf (stderr, "pthread_attr_destroy failed: %s\n", strerror (s));
+ return 0;
+ }
+- return tid;
++ return (intptr_t)tid;
+ }
+
+ intptr_t
diff --git a/audio/deadbeef/pkg-descr b/audio/deadbeef/pkg-descr
index 77d0e5f6f0e6..36674e01a441 100644
--- a/audio/deadbeef/pkg-descr
+++ b/audio/deadbeef/pkg-descr
@@ -18,5 +18,3 @@ last.fm scrobbler; sdk is included
- duration calculation is as precise as possible for vbr mp3 files (with and
without xing/info tags)
- and etc...
-
-WWW: http://deadbeef.sourceforge.net/