aboutsummaryrefslogtreecommitdiff
path: root/audio/gqmpeg
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gqmpeg')
-rw-r--r--audio/gqmpeg/Makefile9
-rw-r--r--audio/gqmpeg/files/patch-ui_pixbuf_save.c19
2 files changed, 25 insertions, 3 deletions
diff --git a/audio/gqmpeg/Makefile b/audio/gqmpeg/Makefile
index 2dd7823ca662..8817a688e1c1 100644
--- a/audio/gqmpeg/Makefile
+++ b/audio/gqmpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gqmpeg
PORTVERSION= 0.20.0
-PORTREVISION= 9
+PORTREVISION= 10
PORTEPOCH= 1
CATEGORIES+= audio
MASTER_SITES= SF
@@ -15,6 +15,7 @@ MASTER_SITES= SF
MAINTAINER?= lyngbol@wheel.dk
COMMENT?= Another gtk-based MP3 frontend
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools \
xmp:${PORTSDIR}/audio/xmp
@@ -25,11 +26,13 @@ RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
.endif
USE_GNOME= gdkpixbuf
+USE_GETTEXT= yes
WANT_GNOME= yes
+USE_GETTETX= yes
USE_AUTOTOOLS= autoconf213 libtool
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
MAN1= gqmpeg.1
diff --git a/audio/gqmpeg/files/patch-ui_pixbuf_save.c b/audio/gqmpeg/files/patch-ui_pixbuf_save.c
new file mode 100644
index 000000000000..2a1590443537
--- /dev/null
+++ b/audio/gqmpeg/files/patch-ui_pixbuf_save.c
@@ -0,0 +1,19 @@
+--- src/ui_pixbuf_save.c.orig 2002-03-09 20:00:13.000000000 +0100
++++ src/ui_pixbuf_save.c 2012-05-09 13:04:57.000000000 +0200
+@@ -24,6 +24,7 @@
+
+ #ifdef HAVE_LIBPNG
+ #include <png.h> /* for png saving, below */
++#include <pngpriv.h>
+ #endif
+
+
+@@ -86,7 +87,7 @@
+ return FALSE;
+ }
+
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp (png_ptr->longjmp_buffer))
+ {
+ png_destroy_write_struct (&png_ptr, &info_ptr);
+ fclose (handle);