aboutsummaryrefslogtreecommitdiff
path: root/audio/ladish
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ladish')
-rw-r--r--audio/ladish/Makefile57
-rw-r--r--audio/ladish/distinfo3
-rw-r--r--audio/ladish/pkg-descr6
-rw-r--r--audio/ladish/pkg-plist27
4 files changed, 93 insertions, 0 deletions
diff --git a/audio/ladish/Makefile b/audio/ladish/Makefile
new file mode 100644
index 000000000000..d727b10be669
--- /dev/null
+++ b/audio/ladish/Makefile
@@ -0,0 +1,57 @@
+PORTNAME= ladish
+DISTVERSION= 1.2
+DISTVERSIONSUFFIX= -g4dcd67d7
+CATEGORIES= audio
+MASTER_SITES= https://dl.ladish.org/ladish/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Session management system for JACK
+WWW= https://ladish.org/
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libdbus-1.so:devel/dbus \
+ libexpat.so:textproc/expat2 \
+ libjack.so:audio/jack \
+ libuuid.so:misc/e2fsprogs-libuuid
+
+USES= tar:bz2 localbase:ldflags pkgconfig python shebangfix waf
+USE_PERL5= configure
+
+SHEBANG_FILES= ladish_control
+
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT= GUI
+OPTIONS_SUB= yes
+
+GUI_USES= gettext gnome
+GUI_USE= GNOME=atkmm,cairo,gdkpixbuf2,gtk20,gtkmm24,libgnomecanvas,pango,intltool:build
+GUI_VARS= CONFIGURE_ARGS=--enable-gladish
+GUI_BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+GUI_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgnomecanvasmm-2.6.so:graphics/libgnomecanvasmm26 \
+ libharfbuzz.so:print/harfbuzz
+
+post-install:
+ # strip
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${STRIP_CMD} \
+ bin/jmcore \
+ bin/ladishd \
+ bin/ladiconfd \
+ lib/libalsapid.so
+ # remove unnecessary files
+ @${RM} -rf \
+ ${STAGEDIR}${DATADIR}/COPYING
+
+post-install-GUI-on:
+ #/usr/local/share/ladish/gladish.ui
+ # strip
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${STRIP_CMD} \
+ bin/gladish
+
+.include <bsd.port.mk>
diff --git a/audio/ladish/distinfo b/audio/ladish/distinfo
new file mode 100644
index 000000000000..590d358a6285
--- /dev/null
+++ b/audio/ladish/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711726210
+SHA256 (ladish-1.2-g4dcd67d7.tar.bz2) = 387c195b2efe4912b48b3e6c9a3feefcc420ef6f457462c0a87a11f8e33b000a
+SIZE (ladish-1.2-g4dcd67d7.tar.bz2) = 659040
diff --git a/audio/ladish/pkg-descr b/audio/ladish/pkg-descr
new file mode 100644
index 000000000000..1c07748df086
--- /dev/null
+++ b/audio/ladish/pkg-descr
@@ -0,0 +1,6 @@
+LADI Session Handler or simply ladish is a session management system for JACK
+applications on GNU/Linux. Its aim is to allow you to have many different audio
+programs running at once, to save their setup, close them down and then easily
+reload the setup at some other time. ladish doesn't deal with any kind of audio
+or MIDI data itself; it just runs programs, deals with saving/loading
+(arbitrary) data and connects JACK ports together.
diff --git a/audio/ladish/pkg-plist b/audio/ladish/pkg-plist
new file mode 100644
index 000000000000..550080aabad4
--- /dev/null
+++ b/audio/ladish/pkg-plist
@@ -0,0 +1,27 @@
+%%GUI%%bin/gladish
+bin/jmcore
+bin/ladiconfd
+bin/ladish_control
+bin/ladishd
+lib/libalsapid.so
+%%GUI%%share/applications/gladish.desktop
+share/dbus-1/services/org.ladish.conf.service
+share/dbus-1/services/org.ladish.jmcore.service
+share/dbus-1/services/org.ladish.service
+%%GUI%%share/icons/hicolor/16x16/apps/gladish.png
+%%GUI%%share/icons/hicolor/22x22/apps/gladish.png
+%%GUI%%share/icons/hicolor/24x24/apps/gladish.png
+%%GUI%%share/icons/hicolor/256x256/apps/gladish.png
+%%GUI%%share/icons/hicolor/32x32/apps/gladish.png
+%%GUI%%share/icons/hicolor/48x48/apps/gladish.png
+%%GUI%%%%DATADIR%%/gladish.ui
+%%GUI%%%%DATADIR%%/ladish-logo-128x128.png
+%%GUI%%%%DATADIR%%/status_down.png
+%%GUI%%%%DATADIR%%/status_error.png
+%%GUI%%%%DATADIR%%/status_started.png
+%%GUI%%%%DATADIR%%/status_stopped.png
+%%GUI%%%%DATADIR%%/status_unloaded.png
+%%GUI%%%%DATADIR%%/status_warning.png
+%%GUI%%share/locale/de/LC_MESSAGES/ladish.mo
+%%GUI%%share/locale/fr/LC_MESSAGES/ladish.mo
+%%GUI%%share/locale/ru/LC_MESSAGES/ladish.mo