aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mpg123/Makefile')
-rw-r--r--audio/mpg123/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index de2f7bae6326..2da6c986d6ed 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -1,11 +1,12 @@
PORTNAME= mpg123
-PORTVERSION= 1.29.3
+DISTVERSION= 1.32.5
CATEGORIES= audio
MASTER_SITES= SF \
https://www.mpg123.de/download/
MAINTAINER= novel@FreeBSD.org
COMMENT= Command-line player for MPEG Layer 1, 2, and 3 audio files
+WWW= https://www.mpg123.de/
LICENSE= LGPL21
@@ -13,6 +14,7 @@ USES= cpe tar:bzip2 libtool localbase pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --with-optimization=0
INSTALL_TARGET= install-strip
@@ -34,6 +36,7 @@ FPU_CONFIGURE_OFF= --with-cpu=arm_nofpu
SNDIO_CONFIGURE_ON= --with-audio=sndio,oss
SNDIO_CONFIGURE_OFF= --with-audio=oss
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_USES= pkgconfig
OPTCPU_CONFIGURE_ON= --with-cpu=x86
OPTCPU_CONFIGURE_OFF= --with-cpu=generic_fpu
@@ -42,6 +45,8 @@ OPTCPU_CONFIGURE_OFF= --with-cpu=generic_fpu
.if ${ARCH} == "amd64"
CONFIGURE_ARGS+= --with-cpu=x86-64
+.elif defined(MACHINE_CPU) && ${MACHINE_CPU:Maltivec}
+CONFIGURE_ARGS+= --with-cpu=altivec
.endif
.include <bsd.port.post.mk>