aboutsummaryrefslogtreecommitdiff
path: root/audio/noise-suppression-for-voice-lv2/files
diff options
context:
space:
mode:
Diffstat (limited to 'audio/noise-suppression-for-voice-lv2/files')
-rw-r--r--audio/noise-suppression-for-voice-lv2/files/patch-CMakeLists.txt21
-rw-r--r--audio/noise-suppression-for-voice-lv2/files/patch-src_common_CMakeLists.txt15
-rw-r--r--audio/noise-suppression-for-voice-lv2/files/patch-src_juce__plugin_CMakeLists.txt21
3 files changed, 57 insertions, 0 deletions
diff --git a/audio/noise-suppression-for-voice-lv2/files/patch-CMakeLists.txt b/audio/noise-suppression-for-voice-lv2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a033a5f9a502
--- /dev/null
+++ b/audio/noise-suppression-for-voice-lv2/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2024-05-18 14:43:53 UTC
++++ CMakeLists.txt
+@@ -4,7 +4,7 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}
+ include(GNUInstallDirs)
+
+ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
+-set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
++set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
+ set(CMAKE_BINARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
+
+ set(MINGW_ADDITIONAL_LINKING_FLAGS "-static-libgcc -static-libstdc++ -Wl,-Bstatic -lstdc++ -lpthread -Wl,-Bdynamic")
+@@ -36,7 +36,8 @@ if (BUILD_VST_PLUGIN OR BUILD_VST3_PLUGIN OR BUILD_LV2
+
+ if (BUILD_VST_PLUGIN OR BUILD_VST3_PLUGIN OR BUILD_LV2_PLUGIN OR BUILD_AU_PLUGIN OR BUILD_AUV3_PLUGIN)
+ if (USE_SYSTEM_JUCE)
+- find_package(JUCE)
++ find_package(JUCE REQUIRED)
++ message("-- Found JUCE Version=${JUCE_VERSION}")
+ else ()
+ # For install JUCE copies all its headers, no one needs them. It also doesn't install actual libraries.
+ # On the other hand JUCE could install libraries during build process (see COPY_PLUGIN_AFTER_BUILD option).
diff --git a/audio/noise-suppression-for-voice-lv2/files/patch-src_common_CMakeLists.txt b/audio/noise-suppression-for-voice-lv2/files/patch-src_common_CMakeLists.txt
new file mode 100644
index 000000000000..79042b6a7a1a
--- /dev/null
+++ b/audio/noise-suppression-for-voice-lv2/files/patch-src_common_CMakeLists.txt
@@ -0,0 +1,15 @@
+- fix build on platforms where sanitizer isn't available: armv7, aarch64, ...
+
+--- src/common/CMakeLists.txt.orig 2023-08-17 05:30:38 UTC
++++ src/common/CMakeLists.txt
+@@ -33,8 +33,8 @@ if (BUILD_TESTS)
+ $<BUILD_INTERFACE:${CMAKE_SOURCE_DIR}/external/catch2>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>)
+ target_link_libraries(common_plugin_tests PRIVATE ${LIBRARIES})
+- target_compile_options(common_plugin_tests PRIVATE -fsanitize=undefined)
+- target_link_options(common_plugin_tests PRIVATE -fsanitize=undefined)
++ #target_compile_options(common_plugin_tests PRIVATE -fsanitize=undefined)
++ #target_link_options(common_plugin_tests PRIVATE -fsanitize=undefined)
+
+ include(CTest)
+ include(Catch)
diff --git a/audio/noise-suppression-for-voice-lv2/files/patch-src_juce__plugin_CMakeLists.txt b/audio/noise-suppression-for-voice-lv2/files/patch-src_juce__plugin_CMakeLists.txt
new file mode 100644
index 000000000000..c7a1ecb8634b
--- /dev/null
+++ b/audio/noise-suppression-for-voice-lv2/files/patch-src_juce__plugin_CMakeLists.txt
@@ -0,0 +1,21 @@
+--- src/juce_plugin/CMakeLists.txt.orig 2024-05-18 14:43:53 UTC
++++ src/juce_plugin/CMakeLists.txt
+@@ -88,14 +88,14 @@ function(compile_plugins formats suffix default_channe
+ # JUCE has a terrible idea of installing plugin during the BUILD process instead of during the INSTALL,
+ # also JUCE wants to install its headers which we don't want at all.
+ # So it's easier to handle it ourselves.
+- if (UNIX AND NOT APPLE)
++ if (FALSE AND UNIX AND NOT APPLE)
+ foreach (format IN LISTS formats)
+ if (format STREQUAL "LV2")
+- install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/rnnoise${suffix}.lv2 DESTINATION ${CMAKE_INSTALL_LIBDIR}/lv2)
++ install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/../src/juce_plugin/rnnoise_juce_plugin${suffix}_artefacts/Release/LV2/rnnoise${suffix}.lv2 DESTINATION lib/lv2)
+ elseif (format STREQUAL "VST")
+- install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/vst/ DESTINATION ${CMAKE_INSTALL_LIBDIR}/lxvst)
++ install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/vst/ DESTINATION lib/lxvst)
+ elseif (format STREQUAL "VST3")
+- install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/rnnoise.vst3 DESTINATION ${CMAKE_INSTALL_LIBDIR}/vst3)
++ install(DIRECTORY ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/../src/juce_plugin/rnnoise_juce_plugin_artefacts/Release/VST3/rnnoise.vst3 DESTINATION lib/vst3)
+ endif ()
+ endforeach ()
+ endif ()