aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/openal-soft/Makefile')
-rw-r--r--audio/openal-soft/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 6674bc2840da..bff0cc015271 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -1,11 +1,12 @@
PORTNAME= openal-soft
PORTVERSION= 1.21.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= https://openal-soft.org/openal-releases/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Software implementation of the OpenAL specification
+WWW= https://openal-soft.org/
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -33,7 +34,7 @@ CONFIG_DESC= Install configuration utility (needs Qt 5)
UTILS_DESC= Build and install utility programs
CONFIG_USES= qt:5
-CONFIG_USE= QT=core,gui,widgets,buildtools_build,qmake_build
+CONFIG_USE= QT=core,gui,widgets,buildtools:build,qmake:build
CONFIG_CMAKE_BOOL_OFF= ALSOFT_NO_CONFIG_UTIL
CONFIG_CMAKE_ON= -DALSOFT_NO_QT5:BOOL=OFF
@@ -58,6 +59,16 @@ SNDIO_CMAKE_BOOL= ALSOFT_BACKEND_SNDIO ALSOFT_REQUIRE_SNDIO
UTILS_LIB_DEPENDS= libmysofa.so:audio/libmysofa
UTILS_CMAKE_BOOL= ALSOFT_UTILS
+.include <bsd.port.pre.mk>
+
+# The following is actually meant for lld 15.0 and later, but the ports
+# framework does not support LINKER_TYPE and LINKER_VERSION yet.
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+# Turn off checking of dynamic relocations, to avoid lld diagnostics about
+# possibly incorrect addend values.
+LDFLAGS_i386+= -Wl,--no-check-dynamic-relocations
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|/etc/openal|${ETCDIR}|' \
${WRKSRC}/alc/alconfig.cpp
@@ -66,4 +77,4 @@ post-install-EXAMPLES-on:
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . \
${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>